Unity corrupting files on save?

I tried posting this question in the Unity course, [Solved] HELP - Everything in Hierarchy disappeared! ( Re-importing reversed but then re-saved and it all disappeared permanently)
but I’ve received no comments at all. PLEASE HELP, This is very serious and I can’t really go on until I get it resolved: While working on Number wizard UI, Using v4.7.2 My saved information in the contents of each level disappeared but the level names did not. I did reimport it and everything was there. I saved it and everything was lost again and reimport did not restore it again. I’ve tried opening in Unity 5.5 but the levels are still empty, I tried opening the asset files in wordpad but found no strings that looked like the names of the missing saved data.

What should I do?? I remember finding out by mistake about ‘h’ hiding all selected verts in Blender . Is there something like that in Unity?

My best guess is that the save function messed up my data, has anyone else had this problem??

I’ll try re-installing Unity 4.7.2 tonight unless anyone has any suggestions.

Hi @walshlg

It’s not something I’ve come across myself to be honest.

You mention that the contents of each level have disappeared, presumably you have expanded assets and clicked on the actual scene, e.g. you aren’t relying purely on the default / initial view within the hierarchy in Unity? The hierarchy view is on display?

I’m guessing you are saving scenes / saving project when you quit Unity?

You’ve mentioned that you have more than one version of Unity installed, are they in separate installation directories?

Have you opened the original project created in the older version of Unity within the newer version of Unity and are then trying to open it again in the older version?

Final thing - can you reproduce the problem? e.g. can you create a new project, create a scene, add a cube, save the scene, save the project, quit Unity, re-opened the project and the cube has gone?

yes that was it, my file structure is a mess as I didn’t understand how you wanted us to save things in repos in the first lessons. It was saved correctly but not in the directory It went to when it went to re-open the project. So I conclude that somehow I must have changed the directory, must have hit ’ save as’ by mistake I suppose, and when it reopened I went to a different directory. How on earth did i do this? i think its because of windblows file handling - it was saving to “this computer documents” rather than specify the path on the drive directly and it looks like I now have 2 “documents” folders!.

Well after this project, going to reinstall and rebuild repos in some sort of a logical pattern.

Thanks for your help.

1 Like


Glad you managed to work it out and can at least move forwards now - great stuff :slight_smile:

Privacy & Terms