Unexpected material behavior

I’ve nearly finished my low-poly dino project. As always, I’ve done a bit of my own thing with the textures. I have some questions about the trees.

I create the tree, alt-D to create multiple duplicates. Then after I had a group of those, I did a shift-D on the lot of them to double my forest.

I have the same material applied to all the trees. But on half of them the “repeat” of the material is very high density while on the other half it behaves as normal. I can’t figure out why the first group is different than the second group. They are duplicates and share the same material. If you zoom in, you see the material is there. The material is just scaled differently.

Any ideas where the setting is? It is the same material - so I don’t think it’s in the material itself. In this image, you can see that some trees are leafy and the others seem smooth. They should be identical and every setting I have checked, they are identical. But yet they are not.



General Q&A note

Help us all to help you.
Please give full screenshots with any questions. With the relevant panels open.
This can be done by Blender itself, via the ‘Window’ menu bar top left-hand side.
On that menu dropdown is ‘save screenshot’.

  • do show the material setup.
  • did you scale things?
1 Like

Here is my material setup. All trees use the same material. I’ve checked scaling and sizes and don’t see any issues there. Not sure what else to check.

I tried removing the material slot and adding it back and re-attaching the material, that did not help.

I deleted all the bad trees and copied the good trees again and everything looks great. So it has nothing to do with the material itself. But on the object, I couldn’t find any differences in any of the tabs. But re-copying the objects did correct the issue.

I would love to know what caused this issue. But it’s not a show-stopper by any means.

Glad it works now.

Silly question, when you apply a single color, or maybe a color gradient, do they all look the same?

Just in case, did you try to select all trees in Object mode, and press Ctrl + A, & apply scale.

I restored the “broken” version so I could do further testing. I did the APPLY scale, no change. I did APPLY ALL and no change either.

Here is the zoomed in screenshot of one of the affected trees.

Going to continue “trying stuff”. :slight_smile:

1 Like

Odd. Happy testing :smiley:

1 Like

Generally, do not use displacement at all. (certainly at beginner level) To work at all it needs a lot of geometry, and has been known to cause problems while being in the material not able to work.
Yes it works but when you specifically set out to make sure it can.

1 Like

What confused me as Blender beginner, many years ago. Is that the object (a cube, a tree), has a different properties set, than the mesh inside the object (all the vertices, creating edges and faces).

The scale of a object is different than the scale of the mesh inside the object!
If you scale the mesh inside an object, the object scale is still 1. And the object looks smaller/bigger.
If you scale the object, it looks bigger/smaller but the mesh data (coordinates) are still the same. This is why you need to APPLY the scale (mesh data and object are synchronized)

Blender works mostly (calculations, rendering) on the given mesh data.
Meaning: the object looks the same in size, but the texture (visible look) can therefore differ.

Most beginners do have strange, unexpected render outcomes.
This is because they accidentally switch on options using wrong hot-keys.
Or switch on/off options to experiment trying to see differences.
This leads to (for Blender internal) unlogical Blender configurations, leading to strange behavior. This happens to us all and will get less with more Blender experience.

Sometimes it helps to start a fresh .blendfile and import (file > append) your object, materials one by one.


Privacy & Terms