UE5 VR Template might be incompatible with this section

Mabe its just me but in UE5 VR Template I had a lot of issues following the tutorial. The teleport circle isn’t a material. Its a Niagara Component.

To add it to your project:

In your build.cs file add Niagra to it.

PublicDependencyModuleNames.AddRange(new string[] { "Core", "CoreUObject", "Engine", "InputCore", "Niagara" });

Instead of having a UStaticMesh for your teleportation marker make it UNiagaraComponent. You might need to create a new Character blueprint if you can’t see the details.

Yes, it is incompatible. You basically want to ignore every asset in the original template while working through this section. However, the project template itself has the correct rendering settings required for this section - this is what you want really. You could effectively delete all other assets from the VR template and create a default level to start working in.

For anyone in the same situation (using VR Template with 4.27 or 5.0), there is a material called M_TeleportCylinder inside Content->VRTemplate->Materials. It’s similar to the one used in the lecture (Just remember to create a material instance before).

1 Like

Yeah, you can retain the assets for future use.