UE5 Live Coding Recompile failed - internal heap limit reached

I’m doing the Obstacle Assault -course and I’m getting failures during Live Coding Recompile almost everytime something is changed in MovingPlatform.h or MovingPlatform.cpp. Usually after a couple tries the recompile succeeds.

My windows page file is set to 4096MB and i have 16GB of ram.

Console error message:
Registered process D:\Epic\UE_5.2\Engine\Binaries\Win64\UnrealEditor.exe (PID: 12676)
Loading module D:\Epic\Unreal Projects\ObstacleAssault\ObstacleAssault\Binaries\Win64\UnrealEditor-ObstacleAssault.dll (0.079 MB)
Loaded 1 module(s) (0.000s, 5 translation units)
Live coding ready - Save changes and press CTRL+ALT+F11 to re-compile code
Manual recompile triggered
---------- Creating patch ----------
Running D:\Epic\UE_5.2\Engine\Build\BatchFiles\Build.bat -Target=“ObstacleAssaultEditor Win64 Development -Project=”“D:/Epic/Unreal Projects/ObstacleAssault/ObstacleAssault/ObstacleAssault.uproject”"" -LiveCoding -LiveCodingModules=“D:/Epic/UE_5.2/Engine/Intermediate/LiveCodingModules.txt” -LiveCodingManifest=“D:/Epic/UE_5.2/Engine/Intermediate/LiveCoding.json” -WaitMutex -LiveCodingLimit=100
Quick restart disabled when re-instancing is enabled.
Using bundled DotNet SDK version: 6.0.302
Running UnrealBuildTool: dotnet “…\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.dll” -Target=“ObstacleAssaultEditor Win64 Development -Project=”“D:/Epic/Unreal Projects/ObstacleAssault/ObstacleAssault/ObstacleAssault.uproject”"" -LiveCoding -LiveCodingModules=“D:/Epic/UE_5.2/Engine/Intermediate/LiveCodingModules.txt” -LiveCodingManifest=“D:/Epic/UE_5.2/Engine/Intermediate/LiveCoding.json” -WaitMutex -LiveCodingLimit=100
Log file: C:\Users\JalipaliPc-risen\AppData\Local\UnrealBuildTool\Log.txt
Building ObstacleAssaultEditor…
Using Visual Studio 2022 14.38.33134 toolchain (C:\Program Files\Microsoft Visual Studio\2022\Community\VC\Tools\MSVC\14.38.33130) and Windows 10.0.22621.0 SDK (C:\Program Files (x86)\Windows Kits\10).
[Upgrade]
[Upgrade] Using backward-compatible include order. The latest version of UE has changed the order of includes, which may require code changes. The current setting is:
[Upgrade] IncludeOrderVersion = EngineIncludeOrderVersion.Unreal5_0
[Upgrade] Suppress this message by setting ‘IncludeOrderVersion = EngineIncludeOrderVersion.Unreal5_2;’ in ObstacleAssaultEditor.Target.cs.
[Upgrade] Alternatively you can set this to ‘EngineIncludeOrderVersion.Latest’ to always use the latest include order. This will potentially cause compile errors when integrating new versions of the engine.
[Upgrade]
Determining max actions to execute in parallel (8 physical cores, 16 logical cores)
Executing up to 8 processes, one per physical core
Requested 1.5 GB free memory per action, 4.62 GB available: limiting max parallel actions to 3
Building 1 action with 1 process…
[1/1] Compile [x64] MovingPlatform.cpp
c1xx: error C3859: Failed to create virtual memory for PCH
c1xx: note: the system returned code 1455: Sivutustiedosto on liian pieni t?m?n toiminnon loppuun suorittamiseksi.
c1xx: note: please visit https://aka.ms/pch-help for more details
c1xx: fatal error C1076: compiler limit: internal heap limit reached
Build failed.

That would suggest you ran out of memory. I’d suggest closing some applications and/or restarting your PC and trying again.

I figured this would be the issue.

I only have UE5, chrome and VScode open, altough chrome does eat up alot of memory.

I’m wondering are there settings I can meddle with in UE or Visual Studio?

It seems strange if a non-realtime operation cannot be set up to use less memory and do the task in smaller chunks.

Have you not tried closing everything except what is strictly needed? And even restarting the PC and closing programs running in the background? As we should at least verify that’s the actual issue before going further.

Privacy & Terms