UE 5 game stutter using Metahuman as Default pawn class in 3rd person game

Hi All, this is my first post here :slightly_smiling_face: I’m new to the world of gamedev and am currently learning the UE5: Action Adventure Gamedev Course. I’m almost done with the first section of designing a simple level using megascans assets and the third person BP character. and the level seems to run fine on my 3060 (12 GB VRAM) even with the scalability set to Cinematic. However, as soon as I bring in a metahuman character and set it to be the Default Pawn Class in the third person game BP, the performance is extremely stuttery and laggy. So far I have tried lowering the game engine scalability settings to Low as well as tried importing the Metahuman from Bridge using the “Low Quality” Export preset. However neither of those helped with the stutter and lag.
I was wondering if anyone could guide me/point me in the right direction on the way to troubleshoot and identify the root cause of the stutter with the metahuman as the level runs smoothly with the default UE5 mannequin. Using UE5.3.2. Thanks a lot

Okay I’ve managed to resolve the Metahuman stutter problem. It’s mainly caused due to the hair on the metahuman. You can view the root cause of this issue by using the GPU visualizer. Start your Game level and then press Ctrl+Shift+, to open the GPU Visualizer.
In my case, it was the Scene taking the longest time and within that were the HairStrandsVisibility, HairStrandsInterpolation and HairStrandsVoxelization taking the most computation time.
Additionally, as mentioned by a few others in the forums, make sure you use the “Low Quality” Export Preset while exporting the Metahuman from Bridge. I exported a Metahuman without any Hair and also set the LOD to 1.
Also to set the LOD, open the Player BP, in the Components pane, scroll all the way down, until you see LODSync. Click on LODSync and then set the Num LODs to 1 in the Details pane. Compile and save.

And that got rid of all game stutters and now I can run the game even on Cinematic scalability settings without any stutters.

Here are the before and after screenshots of the GPU Visualizer

It’s really fascinating that the Metahuman hair is the cause of performance issues. I’m glad you were able to work out a solution, excellent detective work!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms