Tween rocket audio when pressing/releasing the boost key

To avoid the audio to suddenly appear and disappear I tween the sound so it’s more natural, instead of just stoping it to play I set its volume lower so we still hear the engine in the background.

image
When colliding with landingpad or hazard, add a parallel so the properties tweens together instead of sequentially.
image

You need to change few settings in the AudioPlayer:
image

Start with a lower volume (-20 for me) and Autoplay enabled.

1 Like

Privacy & Terms