Trouble with Pixelogic

When I press the download button on the Pixelogic site, nothing happens. It CLAIMS to have downloaded. Chrome even thinks I have downloaded something, and popped up that pixelogic was downloading multiple files, yet… no download occurs.
Obviously I can get textures elsewhere, but I wanted to follow along with what Grant is using in this tutorial, and this has been, by far, the most confounding, annoying part of this entire lecture series.
Anyone know another place i could get those textures?


I’ll reply to myself here, in case someone else has this issue. I noticed someone else mentioned that chrome seemed slower at the pixologic site than firefox, so I tried my downloads again using Microsoft Edge, and had no trouble.
Chrome and Pixologic do not get along.


Thanks. Weird that there should be a difference.

Weird indeed. Gotta be something about how they designed their page.
Glad it worked in other browsers, cause these are fantastic resources!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms