Trouble with opening the project

I have started following this course on a Mac from the ToonTanks section. Since then, almost every time I have tried to open the project. I get this error:

The error states there are missing modules and then it states that it cannot rebuild them so I should try rebuilding the source files manually.

Here are some things that I tried that was able to temporarily fix it:

-Reinstalling Unreal Engine (Worked consistently, but it takes too long)
-Deleting the Quixel Plugin (This only worked once, since I cannot delete the plugin more than once)
-Verifying Unreal Engine (Worked only the first time after I deleted the plugin)

Some of the things I tried that didn’t work:

-Running Editor Development Task, Debug Task, and some others
-Refreshing the code without opening the editor (It only let me do it for Xcode, if there is a way to do it for vs code please lmk)
-Starting Over
-Restarting my computer and checking for updates
-Downgrading Xcode to 5.0 from 5.3 (it didn’t let me use any lower version)
-Opening the file with a lower engine version
-Deleting Intermediate, Binaries, and Saved Folders

Any solutions are GREATLY appreciated. Thank you

Please see the lecture Helping Us Help You and report back with the log.

Do you have other logs? There doesn’t appear to be any errors in that one.

That may be the wrong log. I will send the correct log with this message.

Idk if it matters but I later realized that I only gott this error after compiling in vs code with toon tanks editor Mac development build.

That just says there’s still problems, doesn’t state what it is.

Could you show the output of running that task?

This is the resulting log after I tried to open the file right after running the task.

The first one says it’s already built.

Target is up to date

And from what I can tell, the second one says the project was opened then closed.

What happens when you try to open it? Based on the fact that it says its built, I would assume you are not getting the message popup shown in your OP.

Can you create a blank C++ project in Unreal?

When I try to open it I get the same popup messages.

Also, I am able to create a blank C++ project in Unreal without issue.

I cleaned up some random Unreal files and reinstalled Unreal Engine. After I installed it, instead of just opening it like I usually do, I opened it with “UnrealEditor” instead of “UE4EditorServices.” Still not entirely sure what happened, but for whatever reason it’s working now as expected.

Glad you figured that out as the logs were not making sense based on what you were perceiving.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms