Tips for ensuring Editor performance

When I first load the editor and scene my system performance CPU / fans are low all through editing.

When I play the game as expected CPU temp and fans increase

When I stop the game and return to the editor CPU / Fans remain at a high level.

Do you have any tips to minimize this / return this to normal?

Please note if after playing the game I close and reopen the editor to goes back to low level again.

Note that even when you are not playing the game and just in the viewport and the window has the focus, it is still trying to render the viewport at 60 fps. You can visualize this in the editor preferences under “Show frame rate and memory”

You will then see the stats in the menu bar on the right side:

You can click the “hamburger menu” in the viewport and turn off realtime which will reduce resources while visualizing in the viewport:

You will then see “Realtime off”

You may also want to turn your scalability settings down while in the editor as it takes more resources to develop in the editor than play the game standalone as it technically has 2 worlds loaded in the running process- 1 for the editor and 1 for the running game.

1 Like

tryfinsigabrt has some solid tips! And I’ll double-down on the important part that the editor will always bring some overhead in terms of performance.


This did it amazing could not find anything online about the “issue” / performance.

I think will be really helpful to loads of people.

Thanks for taking the time.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms