Tilemap not visible - sorting layers

Not a question, just something that got me and I wasted a couple of minutes trying to figure out.

I got the background and the platforms working right, but the water wasn’t showing up. It was behind the background even though I put it on the water layer at the layer dropdown at the top of the inspector.

I then noticed at the bottom of the inspector: Tilemap Renderer > Additional Settings > Sorting Layer: Default

I changed that to Water and all was right in the world. I didn’t catch that at first because the other two layers automatically applied the sorting layer setting when I set the layer setting at the top. Hope that saves some time. Like and Subscribe!

Privacy & Terms