ThirdPersonCharacter won't move! What do I do?

I’ve followed this video twice, but my third person character won’t slide to the origin (haven’t made it to the exercise yet). I’m on v4.20.3.

I really don’t know what’s wrong or how to troubleshoot this problem.

I’ve set up a WorldOrigin vector in my blackboard data:

When the game is running, I can see it flowing through the behavior tree and trying to send the actor to 0,0,0:

I have verified that my third person character is set with the correct AI blueprint NPC_AI_BP:

In NPC_AI_BP, I’ve set it up just like the video (even using copy/paste on the vector name WorldOrigin), and printed a string at the end “Made it here”:

When I run the game, I can see that we’ve “Made it here”.

I have no errors in the output log, I’ve verified that the AI blueprint is running, and I’ve verified that the behavior tree is running, and I’ve verified it’s trying to send the actor to 0,0,0.

But… when I push play he just stands there, about 200,300 coordinates away from origin.

Any ideas on how I can troubleshoot this?

Is your character maybe slightly stuck in the level?
I had issues with my Z Values for some reason I had to increase them for some parts, but others of the same height there wasn’t a need for it at all.

I wish the problem was as simple as the Z value. I did try raising him above the world geometry, and I had originally placed him using the “end” shortcut to snap him to the ground. None of these things have gotten him moving.


The patrol point, or the coordinates of the desired destination, can also be at fault here for some reason as well. I do apologize for not explaining my issue well in the first place. Basically the point where I wanted my character to go to had Nx, Ny, Nz coordinates. And even tho my two destinations were in the same height just different X and Y coordinates, my character didn’t want to go to the second one. So I had to change my Z values by 200 or something if I remember correctly on the second point. Up or down I don’t know but worth giving it a shot.

how did you solve this problem?

Unfortunately I never solved this problem. This is the point where I gave up on the unreal course and find other avenues for learning the tool.

My game doesn’t require AI, so this entire last section wasn’t worth the hassle for me.

I just had this problem. I couldn’t even get the 3rd person character moving to the WorldOrigin point and I noticed I kept getting the error “Must rebuild NavMesh”. I checked around and I think this is a bug. I decided to delete my NavMesh and replaced it and everything started working properly. Not exactly a fix to the possible bug, but now I can continue on with the lesson.

Privacy & Terms