The NavMesh isn't built in the entry and underground areas

Hello everybody! Nearly finished the lesson #213 of ‘Complete C# Unity Developer 3D course’ when got an error ‘“SetDestination” can only be called on an active agent that has been placed on a NavMesh’.
The problem is that the Unity Editor builds the NavMesh only for terrain surface, but not for the entry and underground quaters. So zombies inside that quarters don’t have the NavMesh to chase the player.
Any ideas about the reason? Thanks in advance.


Welcome to our community. :slight_smile:

Have you already tried to rebake the navmesh?

And did you paste the error message into the search field of your preferred search engine? I found this potential solution. There are more answers in the linked thread. Please let me know if one of them helped you fix the problem.

Click on the entrance first, then select Navigation - Object and check the Navigation Static box. After that do the same to the underground level and bake.

Hope this helps!

1 Like

Hi, thank you a lot, the link was helpful - just selected the underground floor, checked navigation ‘static’ and baked. Now it works!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms