The Initial Circuit

cu2_s04_unitys_waypoint_utility_scripts

#1

I put in more than 10 waypoints, but I also kinda like how the camera jerks at times -simulating a fast maneuver due to an obstacle. Maybe I’ll have to update later, but for now here it is…oh, but my computer kinda sucks.

I need to get a desktop PC rather than relying on this horrible Intel integrated graphics deal. I’m thinking that’s why my video is all weird after the splash -it looks normal if I launch directly. Or, is that some other thing I messed up?

Anyways, here’s a look:


#2

Hi Joseph,

Well done on creating your level and waypoint circuit.

Regarding the jerky movements, don’t worry too much about this, you replace the WaypointCircuit functionality later and use Unity’s Timeline instead.

Regarding your “my video is all weird after the splash”, I assume you are referring to the black and white terrain? If so, this is down to missing or incomplete lighting data for the scene.

I suspect you have realtime lighting enabled, so each time you make a change within Unity it tries to rebake/calculate all of the lighting. If you run the scene before this process has finished you won’t have the relevant lighting data Unity needs.

To check the theory, goto the menu at the top of Unity and click Window and then Rendering / Lighting Settings.

image

A new window will open, you can dock this with the other tabs if you wish.

With the Scene button pressed you’ll note that there is an option at the bottom to _“Auto Generate”, I suspect this is ticked if so, untick it.

You’ll note the button to Generate Lighting, click that. In the bottom right-hand corner of the main Unity window you will notice a small progress bar, once this is complete the lighting data has been generated.

image

Run the game now and you shouldn’t notice this issue.

Be aware, these lighting options are scene specific, so if you have more than one scene you would need to change these in each. Also, remember to generate the lighting data if you move/change things in the scene. The manual approach requires you to remember to do it if you want to see the changes, but, it saves a bit on your computer’s performance too as it won’t be processing that lighting data all the time, and avoids the issue you have experienced.

Hope this helps :slight_smile:


See also;


#3

On point with the troubleshooting!

Thank you sir! That did indeed fix the weird black and white terrain.


#4

Hi Joseph,

Fantastic, I’m pleased you can move forward with your project again :slight_smile:


#5

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.