The ball sprite(ball.png) will not show on scene

To be stuck on something this easy from the start has got me so bummed out. Its been over 4 hours ive been trying to solve this, nada… Pweeeease help

I have read the discussions that seem relatively similar to my problem and have quadruple check every situation. The camera -10, background -5 z depths are in order.Nothing visible… I tried seeing it in 3d view but again no result…

Also on hierarchy i have tried listing them top to bottom/ viceversa, nothing happened. I have pushed the extremes on scaling the damn thing yet nothing changed.

Done 50 -5000 pixels per unit … no change. Texture type is sprite 2D and UI fyi.

I tried all of these again with creating my own photoshop created ball.png and with a different downloaded png ball… No change.

Thank you for your time

Could you pop a screenshot up with the Ball GameGame object selected in the Hierarchy and so that we can see the full Inspector details.

…and if you expand the details in the Inspector,e.g the Sprite Renderer?

Also, if you double-click on the Ball in the Hierarchy, Unity will typically zoom in and focus on the GameObject, when you do this, what happens, are you able to see it?

Can you also pop up a screenshot with the Ball selected in the Sprites folder and the details from the Inspector.

Also, make sure you have “50” pixels per unit and Apply those, as 5000 will only make it smaller, and, from testing, utterly invisible in the scene, even if you do double-click and zoom in.

If it’s easier, zip up your project files and share them via Google Drive / Dropbox etc and pop a link into your reply and I will take a look for you :slight_smile:

Thank you for the quick reply! Only had a chance to look at it now.

Today started fresh, reopened Unity erased the ball asset inside and re imported it and now its visible!. Now double clicking on it on hierarchy does show it =)

1 Like


Glad you’ve got it sorted, no hints as to what you did differently this time?


Thank you for the help Rob =) The path i took was opening up unity, opening the blockbreaker file that we had previously set up. Then erasing the ball asset that was inside the sprites folder and re dragging the same ball.png asset that was provided inside the assets file. Then re double clicking on it got it showing up on scene. After that i changed the z axis and increased its scale and its done.
Ive done all of this 100 times yesterday =) Maybe i just had to restart unity which was the only thing i hadnt done(unsure ofcourse)

1 Like

One of life’s little mysteries, again, glad you got it sorted and thanks for sharing the steps you took to try to resolve it for other students :slight_smile:

Ofcourse! Hope it provides a simple solution to anyone that comes across something similar…

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms