The AI tanks don't seem to be moving anymore... I have no idea why

Does anyone have any ideea why would my AI tanks not move at all? Most of the settings are verbatim to Ben’s except for a few tweeks in movement speed. The AI tanks were moving at some point, but after the refactorig I think something might have got changed. It’s also unreal’s buggy interface that keeps making me reset meshes and collision each time I compile. The Nav mesh is in place, I even tried adding a new one, the AI controller is set properly, I played with the navmesh defaults and the tanks still won’t move.

I managed to find out that the tanks are actually moving, but they just refuse to move more than a few inches away from their spawn point. They’ll turn facing the opposite way and mostly rotate and they move mostly if I collide with them in order to keep themselves straight. They used to follow me before the refactor. Now my AI pathethic and shy. Any suggestions?

Does using the Visual Logger come up with something more descriptive about what could be the issue?

Thanks Dan, I didn’t know about the Visual Logger.

It’s mostly this. I did get a few times a message saying the End point is not on the NavMesh. I searched some other forums and someone suggested changing Layer and Region Partitioning from Watershed to Monotone in Project Settings > Navigation Mesh. Saying that Watershed fails to create contiguous navmeshes and that’s why NPCs fail to navigate on them. But that didn’t work. I did get less errors. I was thinking it might be a engine bug.

UPDATE:
This also seems to happen. One of the tanks did move a little at the start of the game.

I recall this issue happened when the base eye height for the tank was something weird. I think using the default value of 64 fixed it.

It doesn’t seem to work. If I start and force their movement by moving each of the AI tanks, they seem to be only using the TurnRight method. As if they don’t try to move forward. It’s frustrating enough that each time I compile some of the settings inside the blueprint need to be reset. Anyway, I was trying to find a solution and I have these settings as default. Is this ok? I did try to make them possitive values but it didn’t really change anything. Same with Prefered nav data


It’s inside the Tank blueprint > Movement Component
After I finish this chapter, I’ll go back to the updated course and I’ll try to rebuild the game in a newer version of Unreal. At least now the tanks are aiming and shooting, but it feels as if I am playing with mortars only. :roll_eyes:

It’s a bit hard to debug from just screenshots, would you mind sending your project?

You can do that by using the following link.

Please use File > Package Project > Zip Up Project for creating the zip as it will only include necessary files.

https://gdev.tv/projectupload

I’ve sent it. Thank you Dan!

Your tank blueprint looks like it has bugged components
image

I suggest you delete that blueprint and recreate it. Doing so fixed it on my end.

I do. I have the same issue with another blueprint. It seems to happen after compiling a few times and adding code. I have started this project twice, the first time after assembling the tank mesh to make the blueprint one of the components had that purple sphere. It happens when I try to delete a cached component, add the same one in and try to give it the same name. Even though it’s deleted it says that there’s already a component with the same name, hence why the track has a different name. I’ll try recreating the tank blueprint, but I am sure that it will get a bug after compiling a few times. Thank you Dan, I’ll let you know the outcome!

I’m fairly sure it was cause by changing the parent type of the component that was attached.

Unfortunately making a new tank blueprint didn’t do any difference. What version have you used, Dan?

Sorry I never saw this and I can’t remember, sorry.