Texture Problem

I tried coming up with a custom texture with tessellation from substance, and the plane to which I apply the material quickly disappears and reappears, flickering. I tried placing the object in air, thinking It may a collision problem, searching on the internet, watching more tesselation tutorials, nothing worked
Here’s the material graph

That’s the same config. I use for height map. The only thing I see is that you haven’t plugged in the UV coordinates to the displacement texture. Your plane has enough subdivisions?

I am using the default unreal plane and relying only on the Tessellation Multiplier

Have you tried to reduce the Tessellation Factor to 2 and then increment it one by one?

I have tried your configuration with a texture in a plane and it doesn’t flick, in my case:


Can you post your height texture?

The only thing I see that it could cause problems is that the Height map must be grey and you are connecting the RGB exit to the multiply model. Try to put the red exit in, so if the texture have more than one color, you are using only one channel.

Changing the Tessellation Factor to 2 doesn’t solve the issue, furthermore, it seems to have no effect at all when inspecting the mesh wireframe.
Here’s the height map I’m using

PS it is set to be a linear grayscale, so plugging rgb should’t give problems…

Update: I tried to swap my height map with a downloaded one, and the issue persists. At this point I have no clue of where the problem could come from. Furthermore, it seems that when I select my plane, it stops flickering, but the problem persists in game

I have tried it with your height map and your config (the part I can see) and I have no issues. It works well. I am really stumped.

Are you sure it is a tesselation problem? Have you tried unplugging the other textures one by one? You can put also a color on the Base Color and, with this and the tesselation only, see if it works… You can also change the plane with a cube, to see if the problem is perhaps in the geometry.


An idea:

I don’t know if it can be it, but I read something about flickering sometimes ago, when I began studying materials in Unreal: Try changing ALL your textures except the Normal to the Compressing Settings to Default (DTX 1/5). I don’t remember if the greyscale one accept MipMaps or not, but the flickering can be because the engine can’t calculate the MipMaps and there is a high resolution texture on your scene. Also be sure that ALL the textures sizes are power of two.

It is only an idea, but it can be.

Sorry, nothing works.
It’s so strange that when I select the mesh in the editor it stops to disappear though

Here is what I could capture. The meshes here are disappearing and reappearing, but shadowplay did’t catch these.

Update: I noticed that the issue is present only in meshes with right angles, if that even makes sense

Is your plane at z=0? Try lifting it. I am not sure that it is a texture problem.

I already tried it. Also, if the tessellation value is set to low values, I have no issue. It could be a collision problem / occlusion problem.

Have you tried to increase the bounds of the plane? The bound box of the static mesh.

1 Like

That did the trick! Thank you for you support and patience. :+1:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms