Texture painting leaves out triangles where it just doesn't paint

I was playing around on the evening with some of my own models (very very basic ones) and I ran into some issues. When trying to texture paint them sometimes there are places where it just wouldn’t let me paint. It’s either a specific face it just wouldn’t let me paint on (it works when I paint directly on the texture) or which is even more weird there are like random triangles in the middle of a face where it wouldn’t let me paint. So I basically go over it and it just leaves out a huge triangle shape where it doesn’t apply any paint. If I lower the size of my paint brush so it fits into the triangle it does paint. I have no idea what the issue is, I’ve tried to google the answer but all I could find was issues with uv unwrapping and stuff about normals the wrong way around. Both of this things are fine on my model. I also noticed on one of my objects where I previously had this issue it just went away (probably because I have restarted my pc/blender since the last time). Is this a common blender issue and do I have to restart blender now until this hopefully works for the object I want to paint on or is there an actual reason for this happening to me all the time? I’m using Blender 3.3.1, because the current 3.6.x doesn’t work with Godot 4.

1 Like

General Q&A note

Help us all to help you.
Please give full screenshots with any questions. With the relevant panels open.
This can be done by Blender itself, via the ‘Window’ menu bar top left-hand side.
On that menu dropdown is ‘save screenshot’.

Blender is a complicated piece of software. With many buttons, options, hotkeys, configurations, add-ons, etc. What happens is that Blender gets confused by strange combinations of instructions. Because students are experimenting (what do these buttons do), or have a grip on how Blender works. This leads to unlogical behavior.
this effect goes away after more Blender experience. For example hot-key, sometimes a hot-key doesn’t show any feedback until you see that Blender is acting strange, but why …

Blender is a generic tool for creating 3D environment (objects) in its own domain.
There are some file-type exports that are supported by other 3D applications.
But there is no 100% conversion possible, you’ll need to study/understand what the exported files like .obj, or .fbx support in 3D terms.

Currently, I understand there Blender 4.0 has a change in how items are stored in .blend files. But there is no Godot support other than de basic export types.
You need to study what kind of files Godot imports and what kind of information in those files is managed. Then look at Blender and how to convert Blender features into an exportable file.

1 Like

Okay so right now I wanted to try to force the issue by starting to paint my next object. Usually this issue always happened the first time I was trying to paint a new object. But unfortunately blender doesn’t like me at all now. I can do one brush stroke and if I do another one without saving the image (ALT + S) it just crashes. This has never happened before and I guess you can see I already painted a few things from the screenshot.

This is what I’m currently trying to paint on when blender crashes. As I said, one brush stroke works (no matter how big), and once I start another one it crashes. I guess thats a different issue now. Once my blender actually works again I can try to force the issue I was talking about and take a screenshot (would’ve happened with basically the same settings as I’ve used here).

Thats the answer I see a lot when trying to google my issue.

Godot 4 supports .blend files. You literally save the file in blender and alt tab into godot and it imports it. You can even add some affixes to the objects names to tell godot to create collision or to ignore those objects from the import. This is really great for testing out your levels while blocking out and instantly seeing how things would look like in game while you’re working on it.


Okay so my blender crashing issue is gone. Had it open in a different version where I figured out that some parts of the object where set to material slot 1000 or something like that (which shouldn’t have existed). After fixing that it now runs again in the other version of blender. Weird issue but I kinda start to understand why such weird issue can occur without a common fix to it.

I’ll try to force the issue I was originally talking about again tomorrow, hopefully I can provide a screenshot.


I didn’t know that. But Blender is of course something else than Godot and maybe changing the format internally a bit. Like Blender 4.0

1 Like

As I explained it earlier, mostly user error. Somehow forcing Blender in strange combination.
I had those problems a lot in the past. And now less because of more experience.
Also changing to a new .blend file and APPENGING the previous objects in the new files will help too.

Don’t give up, ask questions.

Do you use AMD cards??

  • try to upgrade your Graphics card drivers.
1 Like

This is some really great advice, haven’t had that idea yet. This will definitely help thanks a lot!

Yes I use an amd card. I’m on linux + newest drivers

I kinda changed my workflow after the issue from yesterday where blender would always crash so now I only start blender 3.3.1 in the background and have it running so the Godot import works and I actually work from blender 3.6.4 which I also have installed. Painted 2 new objects today and haven’t had the issue. So might be a weird version issue or whatever for me with 3.3.1 because there I had this with literally every new object I started to paint. Maybe blender version + linux drivers which didn’t add up in the right way.


In the past (not sure if it is still so), AMD and Blender combinations had some troubles in some cases. Mostly due to drivers and GPU-related calculations.

I’m glad you can continue your work.
Hope to see some!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms