Terminal doesn’t compile

When I debug a code it doesn’t show up in the terminal instead it opens a CMD and runs the code there is there any way I can change in so it shows in the terminal?

Hi,

Welcome to our community! :slight_smile:

In which course and lecture are you? And how di you debug? What exactly did you do?

Unreal engine c++ developer
I wrote a simple code like” hello world “
When I wrote cl hello.cpp it doesn’t compile but when I press f5 it’s debuging and opening a CMD

This is the Unity subforum. That’s why I was slightly confused. I’ve just moved your thread to the Unreal subforum. Have a nice weekend! :slight_smile:

Oh I’m sorry about that
And thank you very much

Could you expand on this? What are you getting? Could you show a screenshot? Did you open VS Code though the developer command prompt?

This is a gif showing what is happening.
And yeah I used developer command prompt to open the vs code tho I had problems in the beginning with it

ezgif.com-video-to-gifezgif.com-video-to-gif

There doesn’t appear to be any gif?

Unfortunately It doesn’t let me upload a gif.
But when I press f5 it just opens a CMD instead of running the code in terminal and the code command doesn’t compile

Would you mind showing your launch.json and tasks.json?

I found the launch.json but not the tasks.json
Here is the launch.json:

Line 16 would be the reason why. You can delete “externalTerminal” and then add a " and you should get a list of options. integratedTerminal should be what you’re after.

Thank you very much it worked!!!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.