Tank C++ class not showing up

I know there’s a similar thread on here but it didn’t actually specify how they fixed it so I’ll ask for myself.

When I make the Tank class by going to C++ -> BattleTank -> Add New C++ class and I make it public, it creates the class, it shows up in visual studios and my file explorer in the right place, but not in the content browser in Unreal. I get an error message that I need to recompile the BattleTank module in order for it to show up but I can’t figure out how to do that no matter how much googling I do. And without it showing up in Unreal, I can’t use it as a parent.

Is there a way on how to recompile the module? Or is there some other fix for this issue?

I didn’t do anything but the class showed up so I guess this problem is solved.

hey I need help I recompile and am no getting the public so what should I do

@Jan_Orzeg-Wydra, What do you mean? You created a Variable in c++ and can’t see it in UnrealEd? Did you put the correct UPROPERTY? can you show us a snipet of your code?

I am having the same issue the pawn does not show up in the content browser in unreal but it did create the tank.h.and .cpp. However now I cant re-associate the parent and I am getting compile errors any idea how to get that pawn icon to show up?

This is a long shot but I remember way back I was having problems finding things in Unreal Editor because there is a small button under the green ‘Add New’ to the left of Filters which you may need to click. This will show all the folders including C++ Classes Folder. I hope this fixes some people’s issue.

I have managed to get the code to compile but without the tank pawn I cannot re associate the parent as shown in the video

Now that it is compiling the tank pawn has arrived :slight_smile:

Privacy & Terms