Suggestion: Rename everything called "menu" in your script

In the entire code for Terminal Hacker, there were I think about four different functions and/or variables with the word “menu” in them. This caused me to get really mixed up about which one performed which action.

ShowMainMenu
RunMainMenu
MainMenu
“menu” as a user input
Etc.

So what I did was change “ShowMainMenu” to “ShowMenuOptions”, changed “RunMainMenu” to “RunUserInteraction” and “MainMenu” to “Welcome”.

I can visualize them being unique now, as they give very specific, explicit instructions. Calling a bunch of things “menu” only confused me more, as I would get them mixed up, and this would further prevent me from progressing. Maybe all of them being similar helped other people, but it only dazed me.

This especially helped me complete the challenge, because I knew exactly what function did which thing. Honestly, everything in this first lesson went by so quickly that some of the information wasn’t detailed enough to stick. Don’t feel bad about using other sources for answers, like CodeAcademy.

Privacy & Terms