[SUGGESTION] Naming Stuff

Hey Sam,
You and Ben are definitely sharp dudes and I’m sure you’re good people as well, so my only grievance is to consider how you name stuff. Your explanations are thorough, but rarely (and quite understandably) have visuals to support what you are saying (that would be time consuming and expensive) so it’s easy to lose context when the jargon starts flowing.

Your lessons have had this breakneck pace in this one respect. You blast through explanations as if it’s regular conversation and the similar names are hard to track since I have no clue of what is being referred to or why.

For instance: in one lesson you used: Score, score, & Score() and ScoreKeeper & scoreKeeper, which is easy enough to write, but when you say something like “Let’s create a private ScoreKeeper… and set that, when we retrieve it from the Score object” means little since I’m not sure what you mean.

here’s a snippet of code from one of the Laser Defender lessons to illustrate what I mean:

  • private ScoreKeeper scoreKeeper;
  • void Start() {
    scoreKeeper = GameObject.Find(“Score”).GetComponent<scr_ScoreKeeper>();
    }

You know coding so well that this doesn’t confuse you in the slightest, but novices like myself have issues with it. It’s fine if it works, but if I run into an issue, it’s difficult to know what I’m looking at and what is pointing at what. Worse still is that I don’t know why you wrote the code like this. Only that it works.

Here’s an example of a way that makes it easier for me:

  • private scr_ScoreKeeper referee;
  • void Start() {
    referee = GameObject.Find(“txt_ScoreBoard”).GetComponent<scr_scoreKeeper>();
    }

Not perfect but it’s easier for rookies (at least myself) to figure out just by studying it a bit. I can see the variable is equal to a script being referenced and what is the text object in my scene. In the previous example however, I have no idea what is what.

Please consider using implicit names as training wheels of sorts (“stabilisers” on that side of the pond :slight_smile: ) to help some of us tenderfoots to actually understand what is meant when you write out and explain your code.

Anyway, if this convention had been done like this in earlier lessons, it’s more likely that I’d understand your explanations and requests. Currently, most of the technical jargon goes over my head.

When you pose your challenges (which I always attempt to do) it’s sad to admit that I’m never close to how you and Ben do it. My attempts are best-guesses, so in all honesty, I’m merely copying your lessons and learning little of coding. I believe this can be remedied a little with naming things in a manner that helps construct context as the lessons progress.

Best regards and cheers!

Hi Chaz,

The forum supports HTML along with BBCode and Markdown in your posts, as such you will sometimes need to escape a character if you want to make it appear normally, rather than as part of a tag for these styles of formatting.

You can escape these characters using a backslash \ character, for example;

\< will render <

You can also indent by 4 spaces for preformatted text, example;

Here is an HTML bold tag <B>

Code formatting can also be easily applied to make your posts more readable.

Hope this helps with future posts :slight_smile:


See also;

Thanks Rob. Corrections applied!

1 Like

You’re more than welcome :slight_smile:

Privacy & Terms