Subdivision surface modifier not working

I am working on a project and when I tried using sub-surf, it doesn’t work
The icon on the modifier stack is red and I have no idea why
Need help

Blender version 3.3.0
Windows 11 x64


Sub-surf modifier wont work

1 Like

This is strange indeed.
I’ve tested it with 3.3.0 like yours.
No problem.

Try closing Blender, and start Blender again.
right click default cube, add sub surf modifier.

Does it work?

Ok it seems to work just fine in a new blend file but still won’t work in the project file I’m working on. Does this mean I’ll have to move my work to another new blend file?

1 Like

Yes! Or you need to find your problem. Remove modifiers, etc.

Open a blank Blender file and select from the main menu, append.
Select and append the items you need.

This is like my fourth time appending because of one problem or the other​:broken_heart::skull:
But alright, thanks, I’ll do that

1 Like

I had this happen to me a few days ago, red iconed modifier for no reason I could see, it had been fine until then, I just deleted it and added a new one, seemed to work fine then.

1 Like

I’ve deleted the mesh and even tried it on new models but still, nothing happened. Still the red icon

I also just tested with version 3.3.0, and no issues. Of course, mine was a fresh scene with no other objects in it, and no other modifiers being used.

1 Like

Grabbed from Stack Exchange. Worth looking into.

Check the Render Properties there is tab Simplify .

If active, it can clamp all the subdivisions to a maximum number using the Max Subdivisions setting.

If set to zero it makes the icon red.

2 Likes

Ohhhh
That makes sense now
Did that to optimize my scene since it was getting slower. Completely forgot about that
Thanks a lot for the support​:raised_hands::100:

2 Likes

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.