Stuck during Course for a few days now, cannot progress

Udemy Complete Blender Creator: Learn 3D Modelling for Beginners
Session 16: Snapping
Place in video session: 02:55 minutes into the video
Please notice* the video was done in Blender 3.2
I have the current version of 3.5.1

The problem I am having: I cannot get the snapping feature of Blender 3.5.1 to work as in the video. I am not able to move past the learning point of how to get snapping to work.

What I have tried to do to fix the issue:
I tried going back over the video multiple times to ensure I am doing the steps as per the video. Step for step, despite the changes of version to Blender. I had started the session in Blender version 3.3.1.

I upgraded to version 3.5.1 hoping the version in blender is broken, and an upgrade would fix it, it seems to have made it worse.

Going back over the video more multiple times, to see if there was some key step I was missing in the process.

Seeking assistance with the course, found the discord channel, started looking for any forum for users to post for technical helps. Found a troll in discord. Upon realizing the discord channel has multiple trolls, I moved back to this forum for helps.

I went back to the video, and watched into the next episode seeing that that video is based on this prior skill being taught… Went back to this forum for helps with the technical issue, I can verify that the snapping feature as per the video does not work.

Steps to reproduce:
Follow along in the videos in the series to this point.
Select a model to move around.
Select the Snapping magnet button to turn it on.
Move the model around with your mouse, it does not snap at all.
It will move, it will not snap. (Key requisite for proceeding steps in the tutorial)
I think I not only have encountered a version error, but perhaps a genuine bug in the Blender software.
Not sure where to report software bugs for Blender project.

1 Like


Please provide the screenshot with your project, it really helps to spot and solve the issue. Snapping has some settings and modes that might cause bahaviour you describe.

For example, if you have snapping to Vertex on, it wont snap until you place your mouse coursor near vertex. If you have no other object in your scene, there will be nothing to snap to. But without screenshot its not really possible to tell.

It is very unlikely, that you have bug in Blender, because snapping is very common and often used tool. But it of course can happen.


Tested snapping in v3.41 and v3.51 and it works perfectly. There are no bugs.
This is almost certainly user error, most likely you either set the wrong snapping options or your object origins are not positioned correctly. Make sure to show your snapping options in the screenshot.
The only way I’d believe it could be a bug is if you’re on an M1 MacBook since these seem to have some weird problems.

1 Like

I can only reiterate what has been said already. Snapping works, any problem is most likely to be in use or expectations of it. Images are vital to chances of help from others.

Snapping can be a little odd to get used to, but once you get it going it becomes familiar.

General Q&A note
Help us all to help you.
Please give FULL screenshots with any questions. With the relevant panels open.
Also, include the lecture time and name/number that is relevant to the problem/issue.
The screenshot can be done by Blender itself, via the ‘Window’ menu bar top left hand side.
On that menu drop down is ‘save screenshot’.
Close ups additionally where they help.

1 Like

I went to set up the screenshot(s), and it was working just fine. I moved on, and have not provided any screen shot, it is fine to close this thread.

I did find as I proceeded past the stuck point, I was having a very few strange behaviors - such as the object was stuck in Y axis, despite it not being selected, and the object would jump about while trying to place it. With that happening, and there are no known bugs in Blender, I am either having a technical issue outside Blender, perhaps affecting the performance, or I am clicking/unclicking something I am not supposed to. (PEBCAK issue)
Thank you for your time.

This was my first tech support to Udemy, is there a format for logging tech support requests in the future? (I know now that I have to include both local to the error as well as full screenshots) I was not finding much in the way of instructions for this, (again, probably smoothbrained it and missed what is already posted in some obvious place)

Sadly no there is no place to prompt people asking for help to tell them the things that are needed in most cases to get some idea of what is going on. Hence some of us have to keep adding the request.
Good to hear it is sorted out more or less.

Privacy & Terms