Strange tracing behavior

Getting a strange behavior when tracing around the stairs. I’m somehow able to trace through the floor. Not sure if this has to do with the trace channel or the size of the cylinder, but here are some screenshots. The larger trace is what it looks like on top of the floor, then I move the marker ever so slightly forward and it’s like it starts tracing through the floor.

Same problem here. It seems for some reason the trace fails to detect the floor in that area. In my case the marker disappears completely, probably because it is under the floor.

hi , I found my problem easily by drawdebug liner

DrawDebugCylinder(World, Start, End, 20.f, 8, FColor::Red, true);

and don’t forget use

#include "DrawDebugHelpers.h"

in header file.for my case the problem was in hot reloaded and I create blueprint again and it solved.

Same problem here, the floor in the areas before the stairs was not hit.

I then checked the floor “SM_COG_Demo_Theatre_Floor_Whole”, and it was missing a collider and in the LOD settings the “Enable Collision” options were not checked, see screenshot.

After doing this everything worked as planned, the LineTrace collided with the floor.

Best
Andreas