Strange materials bug related to default material and material preview

So this bug is very weird and not totally consistent. It happened after I pressed Control + L to link materials of objects, but i pressed it with my mouse in the properties panel instead of the main view. This made blender crash, and ever since it seems like Blender is referencing that material I was trying to link as the default material. Thats the pink color in the images. It’s using it as the background on the preview of my materials (sometimes) and its using it as the color for the icon of the material (sometimes). It will occasionally use the correct background in the preview and randomly switch back to pink. Has anyone else seen an issue like this or know how to fix it? I’m thinking when Blender crashed it must have changed a value somewhere to make this happen. The screenshots are of a brand new blender project file, so it’s not only related to the file that was open when blender crashed.

sounds like you may have accidentally saved a new default file.

To fix this

  1. Open a New file.
  2. Switch to the ‘Shader’ tab
  3. Select the default material in the Properties panel
  4. Delete any extra nodes and reset the values in the Principled BSDF Node. Your node setup should look like this:
    image
  5. Switch back to the Layout View
  6. Save as a new Default Blend file
1 Like

Nope, unfortunately that’s not it. It looks exactly as it does in your screenshot. It is definitely a weird bug and not just a change in the settings. As you can see in my screenshots, the base color is not the one being displayed, and sometimes it displays the incorrect colors in the preview, while sometimes it does not. I think I will try to uninstall and reinstall and see if that works

Did you choose this color?
Because when you apply a bitmap texture and the bitmap file doesn’t exist. Than a color like this is shown.

I didn’t choose the pink color. Maybe it is having trouble finding the correct file then? It’s just weird because sometimes it shows as pink but sometimes it shows the correct color

I have no clue what you did (or why).
But the purple color, done by Blender, is an indicator that you are missing a texture file.
Maybe you relocated (renamed) external files. Or you moved your .blend file to a different location.

I didn’t do anything, I just pressed Control + L and blender crashed, and i have been having this issue ever since.

Switch this option to Blender file and try to find if you are missing a linked file (material texture images / external objects / meshes …)

Here is another method to try:

  1. Navigate to the config file (1) as shown in the image below.

    Note: replace my user name (2) with your own
  2. delete any or all of the highlighted files (deleting startup.blend and userpref.blend should reset blender to default values)

I dont know how to get to this menu

I deleted everything i could, including all data in the registry editor, and restarted my computer, and reinstalled blender, and I am still having the issue. It seems to only be a problem when I open up the preview in the material properties. Have you ever heard of the material preview causing issues for people? It is also usually only when I change the preview render type with the little icons to the right of the preview

Can you save a file and upload it for us to look at?

PS: @FedPete is pointing you here
image

It wont let me upload a .blend file. If you open up a new project and go to the material and open up the preview of the material and change the preview render type, like I circled in red in the screenshot, does it do any weird stuff? Or does it stay as white material on white background? As you can see here it made the material pink, and it’s rendering pink as well, but sometimes the material displays correctly and the background of the preview is pink. Like I said I literally deleted everything related to blender, searched “blender” on my entire C drive and deleted all of it, searched “blender” in registry editor and deleted all of it, restarted computer and reinstalled, and I still have the issue. Now I’m wondering if it’s just a bug in blender

Capture

Last idea, it’s a long shot but I’ve heard of it happening before when I was first going through this course in 2.78. Check to make sure your GPU drivers are up to date.

My drivers are up to date, that’s the first thing I did when I installed blender because it asked me to check. But I do have intel integrated graphics and not a dedicated graphics card, so maybe that has something to do with it?

Thanks for the help

1 Like

No!

Depends on the age of the card and the drivers.
Anything older than 10 years old generally wont work with 2.8 and could cause issues as the driver software that supports the card doesnt support the blender software using 3.0 shaders.

Is this true for Cycles rendering CPU only?
Because then no 3D specific graphic card functions are used?!
The graphics card is then only used to display a bitmap!

The issue tends to present only in eevee (CPU OR GPU)
Has the student tried switching to cycles and checked the results.
Not sure why its limited only to eevee or screenspace reflections being turned on is the other usual culprit if that is indeed the cause.

I suggest uploading to google drive and linking the file here so we can take a look as i cannot recreate this even in 2.80,2.81,2.82 and 2.83.15

I avoided the LTS version as its stable so it should not be a bug in that version.
What happens also if you replace the material as i can see there its not shared by anything and as per Capricos post i actually have deleted the entire contents of the blender foundation folder to reset everything so it might be worth trying that as well.

1 Like

I have blender 2.83.3, the most recent LTS version as far as I know. But your solution seems to be the right one! I switched to cycles and the issue is resolved. The preview of the material takes a tiny bit longer to load, as expected, but everything is now displaying as expected. If this is already a known bug I hope they are able to fix it in the next update because it caused me a lot of frustration!

Thanks for the help everyone.

1 Like