Strange Issues with UE5

Hey!
I don’t know if I’m at the right place here. But I hope, you tell me, if I’m not.
Actually I’m doing the UE5 C++ Course on Udemy. I’m in the Crypt Raider section. Now every day, when I want to continue on the project and open it, UE5 has forgotten all the changes I made the day before. Just compile again doesn’t really help. The compiling crashes with different errors every time. Disabling the live-coding didn’t really help either.
Somewhere I read, I need to close the editor and delete the “Binaries” and the “Intermediate” folder and rebuild it, when I open it again. This helps. But today another strange thing happened. The grabber component disappeared from the BP_Player and I got another blueprint-compiler error, when I started the game again. I added again and it all suddenly worked fine again.
Does anyone have an idea how to solve this issues?

So to be clear, you’re still experiencing problems after disabling Live Coding and then doing a full rebuild by deleting the Binaries and Intermediate folders?

Yes. I need to do a full rebuild every day I want to continue with the project and yesterday the BP_Player forgot completely that it had the Grabber Component on it.
And it’s just a detail, but since I started with the CryptRaider project, my intellisense-fixes for VS Code don’t work anymore, once I added the first C++ class.
Just now I found out, that I have the whole project in a OneDrive-synced folder. Maybe that’s part of the problem too?

Hi there ! I had this issue myself actually a few days ago with the whole grabber thing! Try giving this a go if you want first rebuild from VScode then go back to unreal and enable live coding again then save all files in VScode and then compile with live coding then make your changes and then ensure to save all in the project and then do compile with live coding and then exit the project and wait a few seconds. Go into Task manager and check to see if Unreal is still open down where the background process are if its not and a pink unreal symbol is there then you are good. Go back into Unreal and see if it has fully saved if it is then your problem is unreal not noticing the saves when you reopen it because it was still technically open I beleive. Please correct me if I am incorrect. But when you make a change just make sure you do a live code compile after everything and when you shut down wait a few seconds to make sure its fully shut down before opening again. Hopefully that works ! :slight_smile:

Oh, thank you for this detailed solution. I’ll try it, when I get home tonight. Hope it’ll work.
I will tell, if it worked. :slight_smile:

No worries at all dude ! doing that did seem to work for me so hopefully it will for you too ! :slight_smile: