Strange Hierarchy window behaviour after starting test tools


I was trying to use the test tools on Unity 5.6. After spending some time I managed to fail and pass my first test as explained in the tutorial. However after all those efforts I realized that my hierarchy window no more displayed my scene and objects in that scene. Instead it displays a scene named InitTestScene followed by a long number. And the only child is Code-based test runner. All I want to do is return to my old hierarchy window and access my objects in the game. I did research on the internet to understand what I have done wrong but couldn’t find anything. So I appreciate if anyone could help me find out what is wrong and how can I recover. Thanks in advance!


If you click on the _scenes folder in the Project View, is your scene listed there? If so, what happens if you double-click it to open it?

Hi Rob,

Thank you very much for your quick response to my problem. I tried many thins except opening my game scene again :smiley:
My game scene is located under _scenes folder as you mentioned and when I opened it my problem is solved. Thank you so much for helping Rob! And shame on me for trying tons of things except this one :sweat_smile:

1 Like

Glad to hear you are able to move forward again Taskin :slight_smile:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms