The following logic:
if (oscillate) { stagger = true; }
if (!oscillate) { stagger = false; }
Ensures that oscillate and stagger are always the same, which is not necessarily the logic we want.
I think we want it so we can’t enable oscillate unless stagger is true. So then it should be:
if (!stagger) { oscillate = false; }
Am I thinking about this correctly?