Sphere collision details panel not visible

Hey guys, im in 4.17 and i got a weird issue.

I use the same code as Sam does, but when i create default sub objects USphereComponents, i cannot acces the details panel of the components :frowning: anyone knows what this issue is?

{
I have tried multiple UPROPERTY setups in the header, recompile, restart build
Looked trough Sams code ect. Nothing works ;(
}

B

1 Like

I have exactly the same problem, running unreal engine 4.19.2 and Visual Studio 17 (version 15.7.3)

Had this problem too. Fixed it by changing USphereComponent to UStaticMeshComponent, setting all the properties and then changing it back to USphereComponent. Now details stays visible.

1 Like

Thanks for your reply Vytis_G, well I tried your approach and the problem I had with using USphereComponent was that my tank falling through the terrain. So instead, I have decided to use UStaticMeshComponent. I have scaled down the spheres (5 per side) and simply made the spheres invisible. All is working great with collision etc…

TLDR; Replace the corrupt SprungWheel BP.

I had the same problem in 4.20.3. except when I changed back to UStaticMeshComponent, the details panel remained blank. even after restarting Unreal.

Then I realised I had to comment out the CreateDefaultSubobject lines, build, uncomment and rebuild, the details panel then appeared. and was able to keep them as UStaticMeshComponent. this tactic wouldn’t work for USphereComponent though. those panels would never appear.

Then I discovered I could make the details appear in some weird format by changing VisibleAnywhere to EditAnywhere. but I think some options were missing, like Simulate Physics, MassInKg etc. though it’s all jumbled around. maybe they are there somewhere. :stuck_out_tongue:

After countless re-compiles & engine restarts, I managed to get the USphereComponents to show somehow. but then the AxleWheelConstraint details wouldn’t show… what a mess.

After more digging. I learned that the issue is the BP is corrupting/failing to adapt to changes in the source files. So I created a new BP of the SprungWheel class and all was visible as it should be. Kinda ***** that we have to recreate the BP every time we add/change components. but at least it works.

Side note: I recreated an animal friendly Infinite Energy Generator :stuck_out_tongue:

5 Likes

Thanks Kiefy, this was the answer for me too

@Kiefy, did lot of things to get details panel for Axle and Wheel, restored project by deleting generated code and generating again, none of these things work, deleted blueprint of sprintwheel that did the trick, blueprints work really weird, also I confirm @Kiefy fix worked for Unreal version 21.1 which am currently in…

Yeah, easiest thing for me was to just delete the blueprint and create a new one. I just followed the instruction from when we setup the blueprint the first time. "New Blueprint->type SprungWheel.cpp->voila! Thanks for everyone that gruelled through this before me!

1 Like

I also couldn’t get the Axel or Wheel details panels to appear either. I had to delete the blueprint and recreate it too. At least it’s not too difficult with it mostly being in code.

Deleting the Blueprint and creating it from the C++ class again also fixed all the issues I had with the inherited components. Still good in 4.23.2

Hi, have been having lots of similar issues in 4.23 and VS 2019. Seems to be a hot load issue for me, that seems to corrupt the blueprint, when i compile, and removes the details panel. I now compile and check the Tank BP immediately to see if the details panel is visible for the components, if not I immediately shut down UE4, clean the solution in VS, and then build in VS, before reopening UE4. 9 times out of 10 it comes back, so long as I do it immediately, without trying to change anything.

I hope this helps others.