Sourcetree stuck on Push

Hello. I am following the course and got to the PUSH section. When I click on the PUSH button, Sourcetree pops up the window below but gets stuck as shown.


I wondered whether perhaps it was unable to access github so I clicked on Settings and found that the Repository Settings window is empty (no remote repository paths). I tried to add one, by selecting “Default remote” so that the Remote name is defaulted to “origin” and giving it the URTL/Path to my github account: mygitaccount · GitHub as follows:
image
and the tried to Push again. In this case, it did not get stuck, but Push came back with the following error message:

But if I type my github account path in the browser, I can access it without a problem.
But if I click on the Remote icon I get an error. It seems to be adding another github.com in the path as follows: https://github.com/github.com/MyGitAccount
Any help on how I can solve this would be greatly appreciated! (please note I changed the account name in this exmplet for privacy purposes)
Thanks in advance for your help!

Well, no response but I manage to sort it out by creating a repo on Github first and using the https info under the Clone option in Github as the URL/Path in Sourcetree’s Remote Details window. But would still be interested in knowing if I can do away with creating the Repo in Github first.

1 Like