[Solved] Rising Tide: I made Shader but its not fully working

I got really active on the Rising Tide Challenge of the Floaty Boat quest and tried to make my own water shader.

I love the look on the preview but so soon I add the material created from the shader to the water - pretty much nothing is there like in the preview. Some things are somewhat there but not so good looking.

Vertex does not move as it should and I even swapped out the plane with one with a few more verties.

I’m really sorry for not providing more Information - I’m not sure what you actually need so help me with that. So, I need to ask you to tell me of what you need a screenshot to help.

Thank you in advance!

It could honestly be a whole bunch of things.

You mentioned a preview, so I’m assuming you’re using shader graph?
If you are, the first thing you’ll need to do is use either URP or HDRP - I’d recommend URP to start with.

If you’re creating a custom mesh, double check that your normals are all correct. You’ll get some weird results if some of them are pointing in the wrong direction.

To help see things in action, it might help if you share a short video of your current results, along with a screenshot of your graph. If you can’t do video then a few screenshots should be fine.


Yes, I’m using a shader graph and the project is set up to use URP.

I will add images to the thread so soon I’m back home.

Hello Gary!

Here are the images:

I can’t see anything immediately wrong with your set up (although I may not be looking closely enough).

However, since you’re shader isn’t being applied to the material we’ll start with a painful question - have you actually saved your graph?
In the top left of the shader graph window there will be a “save asset” button. It’s super easy to miss and I’ve done it many times!
Once you’ve done that, you may also need to reset the material in the inspector, just click on the burger icon above the edit button and go to ‘Reset’

Hopefully it’ll be as simple as that. If not, I’ll take another pass at it. If you’re using using source control then a link to your repo might also be handy.

I actually saved it and created a new Material from the shader before I took the screenshot.

I will swap the source control to open in a bit. I’m not sure when I find the time to do it but i will keep you updated.

Until then, I’m happy with every idea of why the material of the shader does not really look like the preview.

Hello gary!
Here is the link to the repo https://bitbucket.org/bavariandodo/floatyboat/src/master/

Looks like the repo is currently private.

Oh, I’m sorry - that is somewhat a habit.

No worries, I’m the same!

I’ve taken a look at your project and the problem is your transform scale.

You’ve scaled the plane in the x and z direction but not the y-direction, this means the vertex displacement has nowhere to go and is causing that weird flickering issue.
Try scaling your plane equally in all three directions and you should get something that matches your preview in shader graph.

I hope that gets you back on track :slight_smile:

Hey @NarutoXD, just checking in to see if you managed to get things working? If not, do let me know and I’ll see if I can lend another hand :slight_smile:

I’m sorry for the late reply but it seems to be working now as intended.

Thank you @garypettie

1 Like

Glad to hear you got it working :slight_smile:

Privacy & Terms