[SOLVED BY MYSELF] Assertion failed: DelegateOwner->IsValidLowLevelFast(false)

Since i try to add the trail particle, i got a problem with unreal.
I followed exactly what the course said, but when i try to shoot a projectile, Unreal engine crashes with this error :

I don"t really know what to do, i tryied to remove the particule on the BP, and recompile + save but that doesnt work and crash again.

Here is the view of projectile BP on unreal

Here my constructor modified for the particle on projectile.cpp :

Here my declarations :

I saw the similar problems (Assertion failed: DelegateOwner->IsValidLowLevelFast(false), Assertion failed: DelegateOwner->IsValidLowLevelFast(false)) but it doesnt work for me.

I also removed my Unreal Engine and reinstalled it but its the same result. I commented the lines i added for the particles trail but… same…

Is that an Unreal issue ?
What can i do ?

I cannot continue the course cause of that … and i dont really know how to fix this error, so if it comes again later, that will be a problem.
Please can someone help me?

I recorded my screen to show you what is the problem : https://we.tl/t-swzp2lW1yb

Ok i just found the problem, you can see on the video i just made for you : https://we.tl/t-KinW0iWPVX
In fact, i found a problem/difference between my original BP_Projectile and the actual one.

I realised after a couple of hours to inspect everything, that somethng was wrong on my projectile BP, the projectile mesh s name is RootCompnent instead of Projectile Mesh and the details are not available on the right side (

But Why ? I didn’t change anything and suddenly the things changed by itself :confused:.

So I decided to recreate a new blueprint from Projectile C++ class on unreal engine, and i called it BP_Projectile2, and thats magical, this new BP has the good and original components hierarchy (on the left side
Capture d'écran 2024-02-17 223123
Ok now i can play with the projectile effects. BUT now there is another problem and i repeat i didn’t change anything except reinstalling Unreal Engine.

The new problem is : When i go forward, my tank doesnt want to shoot projectiles… in the other directions (left, right, back) that work, but when i go straight it doesnt work (you can see that on my video joined at the top of this message).

So strange, i think that my Unreal engine is crazy or possessed by a demon.

Do you have a solution for that, i have no idea how to fix it ?

Ok i found the second problem.

The source came from the distance between projectile spawn point and the base Mesh of tank. As the projectile spawned to close to the tank, when i go straight and shoot straight the projectile is destroyed because the tank touch it cause of its speed. I just increase that distance and then all is ok now.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms