Solution: "Quick Actions and Refactorings" not appearing

Hi everyone,

I was having an annoying issue with VS. Hopefully this will save someone time.

Anytime I highlighted my code and clicked “Quick Actions and Refactorings” like Rick instructed…nothing happened. I tried restarting, nothing happened. I tried pressing the hotkeys shown in the dropdown (CTRL + . ) and nothing happened.

I finally found out that highlighting the code and pressing CTRL + R + M achieves the same results as the video.

With that, I have a suggestion for the creators of this course. Rick specifically said that he didn’t want to add a section detailing his VS studio set up. But honestly, this is like the 5th time I’ve lost significant time becasue my VS studio doesn’t behave the same way. It would be extremely helpful to be able to take 5 minutes and have the same settings as Rick…Or at the very least an optional primer on learning the VS software.

Thanks for the suggestion with this. Is it just with the quick actions and refactorings in order to extract a method that you’ve found was not working, or have there been other aspects of VS Code which haven’t worked as expected for you?

Hi Rick,
Thanks for the response! Unfortunately, just about every aspect of VS is behaving differently. No autocomplete, no suggestions, no red squiggly lines…none of the special features seem to work. I have checked through Microsoft forums and played with the settings but I can’t seem to replicate what you have.

I know that I can do most of what you’re doing manually, and that’s what I’ve been doing. But because I only have a limited time during the week to work on this course, it does get a little disheartening to feel like I’m getting derailed so often.

Anyway, thanks again for the response. I’m sure I’ll get it figured out soon enough!

Love these courses and I’m looking forward to being a VS wizard.

Hi Cole,

This sounds as if there might be a problem with VS. Have you already watched lecture “Fixing Visual Studio Problems” (currently #4)?

Hello Cole,

I’ve had similar problems and following the instructions in this link worked for me. Maybe this will work for you aswell.
Intellisense Not Working with Visual Studio (Fix) - Unity Forum

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.