Slow compile time does not work on Linux

Unreal Engine 4.24

Hello, I’ve tried the slow compile-time solution editing the file, but it does not work on Linux. Unreal is using Mono to compile on Linux.

I have a good pc spec, I7 7700K @ 4.5ghz with 16GB of ram @ 3200
Any other ideas to improve using with Mono?

UPDATE: I disabled the unity build and added the flag bForcePrecompiledHeaderForGameModules.


        DefaultBuildSettings = BuildSettingsVersion.V2;
        bForcePrecompiledHeaderForGameModules = true


        PCHUsage = PCHUsageMode.UseExplicitOrSharedPCHs;
        bUseUnity = false;

Those options seem to have improved the compilation time, but still higher than 30 seconds.

That was specifically for the reflection code generation step where it took some time even when there weren’t any changes need for reflection.

Privacy & Terms