Sketch with grease pencil

I am trying to do Section 5, lecture 104. In the beginning of this lecture Mike shows the drawing with a grease pencil. Then when he switches to Edit mode, there are vertices along the line and whilst in Object Mode the drawing is outlined in orange.

I do not get the same results. I am using the June 11, 2019 build. Here is a picture of both Object Mode and Edit mode of the same object which is the ground. You’ll note that the object is highlighted in Object mode but in Edit mode there are no vertices visible.

Has something changed since this video was made and will it make a difference in the outcome of the lesson?

I just watched the rest of the video lecture and I do not believe I can do what is shown here because there are no vertices for me to manipulate in Edit mode. I cannot move the lines at all in edit mode (or at least not the way that it is shown in this lecture). And if there is another way of moving the parts in edit mode than I haven’t figured out how to do that.

Hi Richard,

I went though this lecture recently and not had any issues but i have the 10th of june build.
There may be a new build today as i havent checked yet but by all counts this should be working.

Let me know if the new build fixes it if there is one or if not let me know

Okay, this problem did happen with the 10th of June build. I tried it in the 11th of June build with the same effect. So, I must have something set up wrong or I am missing something in listening to the lecture. I will try again today with the 12th of June build.

Thank you for the reply! :slight_smile:

Even though I cannot see the vertices in orange (or any color) I was able to grab sections of the drawing by clicking on it and assuming I clicked a vertex then hitting L (link) on my keyboard. I was then able to move the particular line where I wanted it.

The other problem that I am having is when I am in draw mode. If I choose a tool for drawing any of the provided shapes i.e.line, arc, rectangle, or circle, I cannot see the cursor to know where I am drawing on the screen. I have to just draw the shape where ever the cursor may be and move it after I have drawn it. And, yes, I have set my preferences back to factory preset just to make sure I haven’t change something in preferences that may be causing my issues.

At any rate, here is the Grease Pencil challenge completed for my Animated Lamp.

@Michael_Bridges Any suggestions?

Still an issue with today’s build? Is it your mouse cursor - it is really difficult to see!

Does this help?

What is missing is the vertices in the grease pencil line. The line looks the same if I click on it or not. But, if I click on a grease pencil line and then use L to select all linked and go into edit mode, I can move that line around but still can’t see the verticies.

I hope that clarifies the problem that I am having. I have been able to work around it but it is annoying.

Maybe, I can clarify this better.

The picture on the left is from this lecture’s video. I see orange dots where vertices are in the video. The image on the right shows my screen in Blender 2.8 (today’s build 06/17/19). There are no orange dots on the lines even after selecting everything.

If I wanted to move a specific line or part of a line, it would be difficult without those vertices visible. So, I obviously have missed something in the setup because the behavior of my grease pencil is not the same as I see in the lectures.

BTW I really am enjoying all of these lectures and appreciate the amount of effort put into them!
:slight_smile:

I don’t recall @Michael_Bridges mentioning this in the video but you may need to turn up the vertex opacity in order to see them.

1 Like

Well, Now That is much better. I do not remember Michael mention this but you would think it would be set that way as a default. No?

Thank you for the comment. It was VERY helpful!

It definately would have got me if he hadn’t mentioned it in the Grease Pencile section of the environments course

1 Like

The thing is is this IS on by default so i wonder if there was a build at some point where it was off and thats what has happened and its kept the preferences.

Thanks for the catch on this one @Capricas_Kirito, I had completely forgotten that was there.

Might remember next time now :slight_smile:

1 Like

:+1:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.