Simple rocket and help required!

Okay, here is the simple rocket that I haven’t customised much yet, in all it’s dodgy, phallic glory! :slight_smile:

One thing you’ll notice I’m missing in my Unity layout are those wonderfully useful controls in the top right of the working window. They’ve been missing since I started with this install of Unity, and no matter what I try, I can’t seem to make them appear! I seem to recall that they were there in old installations, I don’t think I inadvertently switched them off at any point, and no amount of Googling or searching has led me to a way to make them appear. I’m also missing the transform arrows when I select objects in the scene. I’m getting by without them, but it’s so much easier to manipulate stuff in the scene with them. Any ideas what I need to do to make them all visible?


These get shown/hidden when changing from 2D and 3D views, try clicking on the 2D button and then again and see if the controls re-appear.

Hope this helps :slight_smile:

1 Like

Fraid it doesn’t make them appear. Clicking once puts it into the 2d view, but clicking again just gives me the x,y and z letters, but no little gadget associated with it. It’s almost like it’s switch off globally somewhere. :frowning:

Which version of Unity Jim? There was a reporte issue, but that was long ago, in a galaxy far far away… Unity 4.6 I believe…

Some articles on line suggest pressing “W”, that’s the key for the transform tool, but I think these may be related to the transform on a GameObject as opposed to the Scene Gizmo, could try it I suppose.

If you were to right-click in the cenre, where the Y and X letters would cross if you drew lines from them, do you get the context menu for the gizmo?


If so (appreciating its unlikely), what is selected?

That aside… the next things I’d try would be;

  • same project, new scene, is it still an issue in the new scene?
  • new project, new scene, is it still an issue?
1 Like

Hi Rob, appreciate your advice.

I’m running 2018.2.5f1. Every new project I’ve created so far in 3D has had this problem, so tried it again and yes, it’s still a problem. There is a Unity update pending - I put it off at the start of the course, but might try running that now.

And when I right-click in the area of the displayed axis, nothing happens, but just below in the same faint writing is the toggle for perspective or isometric views,and if I right click on that I do see that menu. I’ve tried all the variations.

This is really odd…

Out of interest, what is selected by default when that context menu appears?

Regarding the update, I’d probably do a complete uninstall and then a complete re-install if I were you.

Another thing we could try, not sure whether it would make any difference, but if I was to create a project here, zip it up, and send it across, you could open that and see whether there’s any change, e.g. is it a project default that is being applied somehow to all your projects, but if you open up one created elsewhere, whether that may override the setting.

Just creating a project now, which I’ll upload here… I notice the “Template” option in Unity Hub when creating it, I left it on 3D.

1 Like

Well, the update hasn’t fixed it. I’d heard the w key thing, but that didn’t do it. And I’ve seen someone suggest opening a new scene tab, but the 2nd tab has the same issue. I guess there isn’t much else to do but as you suggested, ripping out Unity altogether and installing it afresh :frowning:

Here’s an empty project, 2018.2.5f1 (I think)… just on the off chance opening up a project from elsewhere help. (5.0 MB)

With regards to the second Scene tab… did you close the first tab first?

1 Like

Hi Rob

Thanks for the test project. I tried opening it directly from Unity scene file in the assets folder, it opened, but same result I’m afraid. The Gizmo and transform handles are nowhere to be found.

Edit - and yes, I tried firstly adding a new scene. And then closing all open scene views and adding a new one.

This really is quite the puzzle… A mystery wrapped within an enigma! :slight_smile:

I would probably go with the complete uninstall and reinstall then and see if that resolves it.

Are you using Windows or Mac or other btw?

1 Like

It’s Windows. Yeah, I’ll uninstall and reinstall when I reach a convenient break part in the course next. Unity is HUGE and it takes ages, so building up to it!

Thanks for your suggestions. Hoping the new install sorts it out.

Yeah it can be a big download although if you don’t install everything you can make it a bit more reasonable… Documentation, example projects etc, and be selective over the support platforms, Android, iOS, Windows etc…

Do let me know how it goes, your experience, whilst frustrating could also prove useful to someone else who may encounter the same issue.

Jim! I think I have found the problem and solution…

Watch this video and then check the settings at your end…

So, if you goto Edit / Preferences and then select Colors, then check the alpha for the following;

  • X Axis
  • Y Axis
  • Z Axis
  • Centre Axis

By default, mine were originally set to a value of 237.

Because these are Unity preferences, they would persist through each project, and, potentially, if stored in the registry, possibly through re-installation, depending on how thorough the uninstall is.

Hope this helps :slight_smile:

Hi Rob,

I’m sorry to shoot down your theory, but I had actually already looked at those settings, although I had another go after watching the video just in case I’d adjusted the wrong ones!

Here is a pick, all my alphas fully turned up;

I reset to defaults a few times, which like yours - turned all mine to 237. Only difference I found in turning the axis alphas right down was that the text for x,y and z (and the padlock, etc) became dimmer, but still visible. Turning them to max made the text brighter. It’s almost as if the actual graphic images for the components for the gizmo are missing in Unity.

I’ve also checked the Gizmos drop down menu, and everything except 2D box colliders are enabled.

The mystery continues! But thanks for digging deeper :slight_smile:


Awww, that’s a real shame, I really thought I’d found the issue with that one… grrr… back to the reinstall route then perhaps…

Just for completeness on this matter, I was using my old PC when i started the course and hit this problem, I’ve since finally invested in the components for and build a much more capable PC with which to finish the course. Fresh install of Unity, and a capable graphics card now in use, problem is sorted. No idea what it actually was. I had a few visual settings in Windows for icons, so it possibly might have been that, but really not sure.

Anyways - I now have all the right gizmos and arrows, and it is SO much easier to work with the prefabs! :slight_smile:

1 Like

Hey Jim,

Glad to hear your gizmos are all in working order, enjoy the rest of the course! :slight_smile:

1 Like

Privacy & Terms