Should sculpt tool movement be so weird?


I’m learning in UE4.14.3 and when I’m using the Landscape Sculpt tool, the tool’s movement is a kind of weird. When I’m pressing LMB and moving the cursor around, it feels like it has some inertia, so it’s pretty hard to move the sculpt cursor the way I want to.

Is it ok or I can setup this behavior somehow? Also I’m using mac and magic mouse, but for other cases (moving objects and so on) I don’t see this inertia.

I found on a PC with a nvidia geforce 2Gb 660 GTX lanscaping lagged to the point i made spikes and had 3-4 second pauses. I upgrade to a 680 and the issue stopped.
As i dont know your machine spec i would suggest that would be the first check and second background processes :slight_smile:

It doesn’t looks like lags or low performance (while FPS counter became low when I’m sculpting)… Rather it looks like my sculpt cursor has some inertia or acceleration when moving. Don’t know how to explain, but it’s pretty hard to “draw” landscape. I have to do it by separate clicks instead of click-and-drag.

My specs is:
CPU: 2,9 GHz Intel Core i5
GPU: NVIDIA GeForce GT 750M 1024 MB
RAM: 8 GB 1600 MHz DDR3

Sadly thats exactly what happened with me as well the fps dropped to around 1-5 or even 0 from 160fps.
I dont know much about gpu’s in laptops but as its only 1Gb in memory it would be my guess that is the issue.
Sorry but i dont think i can help more here hopefully someone with laptop knowledge will pick up the thread :slight_smile:

It’s not actually a laptop, but Apple is using laptop-class GPU for iMac’s as well :frowning:

Ok, thanks anyway! Probably I have to make upgrade in case if I want to work in UE4 for some more-less real projects…

1 Like

I have a mac pro with 2x the top FirePro cards in it, and I still get weird movement you’re talking about … it’s not relating to that for me, but rather seems to be a function of the nature of how unreal is performing that action. I noticed that ( and this is for myself ), I only get this effect if I use a mouse ( ala click+drag ). If I use my wacom tablet i do NOT have this experience.

What I found helps is if you pretend mentally that it’s like sculpting clay. You take small precise little slices that adds up to what you want ( be them up/down, whatever ). I found that long broad strokes are all over the place where I didn’t want, where you click + drag, and just expect the tool to “do it”. Instead, you make small strokes, back and forth ( i usually use some sort of elliptical back and forth ). This means you need to adjust your tool setting to reflect whatever style you tend to work with, and let’s not forget be patient.

I wonder if this is isolated to mac then but i did notice on my old GPU that unreal only slowed down when i was actually raising the terrain.
This certainly is a wierd issue though.

Privacy & Terms