Shift select doesn't work?

I’m trying to shift select multiple vertices but nothing happens, only ctrl select is working, but ctrl select seems to select everything in a line between the original selection and the next instead of individual vertices.

as you can see i only want to select the vertices highlighted in green, the top and bottom one, but it selected everything in between.

i tried removing doubles
i tried wireframe mode
shift select does nothing

I just tried resetting to factory settings and still, shift click doesn’t let me select multiple objects or vertices

Maybe the short cut key change on user preferences

1 Like

Yeah but i never changed any shortcut

Have you checked to see if this is set?

1 Like

What do you mean?


I meant, after the suggestion about checking your preferences by @wally_alexandre, did you check the preferences to see if it was set to a different key, or, just assume it should be ok because you haven’t changed the key binding etc.

1 Like

I checked it, but i couldn’t find the keybind. Sorry the input tab is overwhelming and full of stuff so i might have missed it, can you show me a screenshot of where it is?

I also did a factory reset so everything should be back to default

In Edit Mode my default appears to be CTRL + Left Mouse Button also. If you want to change these key bindings, you can go to Fiile / User Preferences ( CTRL + ALT + U )

In the User Preferences dialog window, click on the Input tab at the top. Blender has a lot of key bindings, but one of the easy ways to find things is to use it’s search at the top right. If you use the drop down to the left of the search field you can select whether to search on the name of the thing you are trying to do, or, on the key binding.

So, if you leave it on “name”, then you may want to enter something like “select” as the action your are performing. This brings up quite a few results, filtered from the whole set of preferences, however, if you change it to the “key-binding” option, and then enter “ctrl right mouse” for example.

You’ll also note on the left hand side of this user preferences screen there is the “Select With” option, where you can change from left/right buttons. If it were me, I’d probably just get used to using the Ctrl key and not worry too much about it being stated as being the Shift key in the course material.

On a related note, if you hold down the C key whilst in Edit Mode you can use the circle select which is quite a nice way of selecting multiple vertices also, especially as you can use the scroll-wheel on the mouse to change the size of the selection circle to refine what you will select.



Hope this helps :slight_smile:

Updated Fri Aug 10 2018 14:07

I have discovered that both Shift and Ctrl with the Right Mouse Button appear to do the same multi-selection for myself.

1 Like

Thank you very much that was very helpful, just one final question if you don’t mind.

can you explain this behavior, when i have multiple vertices or faces in a line, example 3 vertices, when i ctrl select the first vertice and the last one, as in 1 and 3, the one in the middle gets selected too, as in the number 2 vertice, but i didn’t select the number 2 vertice, the tool just decides to select everything in between my too selections.

Sorry English isn’t my native language so I hope my description made sense. There’s also the screenshot in the original post with the 2 vertices I’m trying to select highlighted in green.

No need to apologise for your English, it’s very good and you are very well understood :slight_smile:

Regarding the selection, I’m not entirely certain. If the selection went all the way around then it would indicate you have a loop-selection, but this doesn’t appear to be the case in your screenshot.

It might be handy to provide the same screenshot of the issue again, but showing which options/tools you have selected.

To have a little test, I’ve opened Blender and, using the default cube, removed the front and back faces. Then sub divided all of the edges on the front of the model. I’ve joined those vertices diagonally, horizontally and vertically, creating a vertex in the middle of what was the original face.

If I select the bottom middle vertex, and, holding Ctrl and then right-click on the top middle vertex, it selects the vertex in the middle. However, if I use Shift instead of Ctrl and repeat the same process (having un-selected everything first), only the bottom and top vertices are selected, not the middle one.

I would suggest that using Ctrl is therefore a short-cut which will get you all the vertices in between the two selections, where-as using Shift is simply incremental.

Hope this helps :slight_smile:

1 Like

Oh my God, i figured out the issue, due to my disability i can only use the on screen keyboard, and it seems like the on screen keyboard doesn’t register shift clicking, only crtl clicking, sorry for wasting your time


Aha! Well done for working it out yourself, and it’s not a waste of my time, happy to try and help and who knows, this topic may end up helping someone else also. Glad you can move forward again :slight_smile:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms