Sharemygame.com stuck processing file

21_th_cu2
terminal-hacker
3d
#1

I tried to upload my hacker.zip file to Sharemygame.com but I think it got stuck on the processing step for some reason. here is a screenshot:

How long do I need to wait for the processing to finish? I don’t even see the circle that animates when the instructor uploads their game in my browser. I am using the latest version of Chrome to access the website.

#2

Hi David,

This issue often occurs if a standard .zip format hasn’t been used, or if the zipped file is larger than 100mb.

On a successful upload it only take a matter of moments usually, depending on the size of the zip.

1 Like
#3

I had the same problem at first. I found that I had missed some of the files when I created the zip(apparently the index file is vital). I found that when I made my first build, I sent it to my “Downloads” folder like Ben does in the video and for some reason it placed the index file separate from the other build files.

Trying to upload that gave me the never ending wait…

So I rebuilt, selected a specific folder within my main project folder and everything went there. That then zipped and uploaded no problem. It did only take a few moments, but there was never any pinwheel. That might no longer be a thing.

Hope that helps. Good Luck!

1 Like
#4

Its what actually loads your game. The ShareMyGame website, along with Itch.io and others just provide an iFrame for this page to be loaded into.

:+1:

#5

Apparently the website expected there to be a folder in the .zip file that contained the index.html file. So, when I just asked Windows to create a zip file with the index.html file at the top level it wasn’t able to find. When, I put the index.html and related files in a folder and asked Windows zip that folder then the website found it.

1 Like
#6

Aha… so it was the structure.

I think there was a video, possibly even on the ShareMyGame.com website which showed the process, but I think it may catch a few people out.

During the build process you normally point that at an empty directory, in most cases you’d probably create that at that point, that’s the folder that needs to then be zipped.

Glad you’ve managed to resolve the problem and can move forward David! :slight_smile:

#8

Wow, been stuck on this for like 30minutes now, I had Zip the folder as a .rar instead of a .zip

Thanks!

1 Like
#9

I have the same problem with the processing part never completing… I’ve zipped up the parent folder so it has a build folder, TemplateData folders inside along with the index.html file… I’ve downloaded Winzip and tried that as well, but nothing seems to work… Not sure why… Any additional help would be appreciated.

#10

I have tried every method suggested here and still my game is stuck in processing. It’s only 6mb. I’ve tried 7zip, winzip and winrar to make a zip file. No go. Is there any solution for this?