Shading problem

Hey :slight_smile:
Does anyone know why my wall is darker on one side?
I think it happened while I was adding materials but i’m not sure.

for reference - here is another wall where it doesn’t happen:

also, on the layout view it looks like this:

Thanks so much for the support on these forums, it helped me a lot!

1 Like


Are they LINKED duplicates (using alt d)? Then they should be equal in look.

If they are just copies (using shift d), then check if all faces are pointing to the outside. In edit mode select all faces, and press shift-n to normalize faces. You can check them manually. Tick ‘Face orientation’ in “Show overlays” button (top right).

Or use shift alt z ! Everything needs to be blueish, not red.

Check also for object duplication on the same spot and or double vertices.


Normals backwards is the most likely.
But check you do not have 2 whole object in the same place.

1 Like

Hi, thanks for the reply :slight_smile:
They are not linked duplicates,
and it seems that the faces are pointed outside:

Also tried merging by distance and ther aren’t any double vertices.

Any other ideas?
Thanks again!

1 Like
  • Did you change, or modify the material of that object?
  • Did you apply a texture to that object, I see some sort of smoothing going on.
    Remove smoothing.
  • Remove material

Look in the Mesh object data properties tab, green triangle.
Down to the Geometry tab, See if there is an option to ‘clear custom Split normals’. If so click it.

1 Like

Privacy & Terms