Sample placement in BlendSpace

In the screenshot below, the whole red line is “50% fwd + 50% idle”, i.e. not “right” animation blend, even though it covers the yaw range of [0…45] degree. The “right” animation starts to be blended in only after the yaw is 45 degres or more.


(the horizontal axis is the yaw, from [-180…+180], the vertical is the speed from [0…100])

Is there another way to place the samples so that the blend would correctly cover a “50% fwd+50% right” for the 45degre, then do a idle->walk->job based on the speed?

I’ll need to look into this but I think you can achieve what you want with the different smoothing settings?

Blend Spaces in Unreal Engine | Unreal Engine 5.0 Documentation

Just FYI, I’m asking more out of curiosity than need.

If I understand the documentation correctly, “smoothing” is related to how to change from one set of blend to another set (i.e. the journey). The issue is more about the choice of blend (i.e. the destination).

This is what the blend weight looks like (with red = forward, green = right, blue = idle) depending on the direction of the triangulation (diagonal). Note how visible the diagonals are, and the image center is either “blue+red” or “green+red” with 50% ratio.
Blend

This is what it should be, where the image center is “25% red + 25% green + 50% blue”
Blend3
33%+33%+33% would also work I think, but I don’t know how to draw that :stuck_out_tongue:.

I think I found the solution.

  • Enable the Use Grid setting in Input Interpolation of the Asset Details panel
  • Then in the Axis Settings of the same panel, select the right amount the Grid Divisions. Your graph must have one animation but grid point.

Then in the grid, I saw that I had the right proportion of blending (25+25+25+25, i.e. 25+25+50 since “idle” is there twice):

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.