Remove doubles was renamed to Merge by distance

Just the information that they renamed this function


I found the merge by distance option but this did not work for me. Any tips?

A lot of people seem to get caught out on this one. The most common reason is that this function only works on one object at a time.

For example, if you add a cylinder and then a sphere as a separate object you cannot merge the vertecies between them. However, if you add the cylinder and then go into edit mode before adding the sphere then you can merge the verticies.

In the first example, you created two separated and independant objects (ofter refered to as meshes) while in the second you added additional mesh data to the cylinder’s mesh and were left with a single mesh. Since Merging Vertecies is a Mesh operation it will only work on a single mesh hence, my opening statement.


I just had same problem and got stuck thanks

yep i’m having same issue. Remove doubles is not showing and having no luck so far.

Remove Particle Duplioject ? if press F3 cannot get REMOVE DOUBLES even on menu

Thank you! This was exactly my issue. As long as the vertices being merged are in the same object then “Merge By Distance” works as it is supposed to.

1 Like

A quick note if you do happen to add two separate objects in object mode and hence unable to merge vertices by distance you can select both objects in object mode and ctrl + j or right click and select join to join the two objects and you will then be able to merge the vertices by distance.

1 Like

Is happens the hurt 2.7 9 work very much the same is 2.8

I was successful with adding the second object in edit mode but when I went back and tried to add both objects in object mode, then select both and join them with ctl-j, it said that no vertices were deleted when I did mesh-cleanup-merge by distance.

I must have done something wrong the first time. Tried it again and it worked.

Hurray I got it to work.
What I did was in an in object mode I joined the the two objects immediately going into edit mode and then selecting al snd then mrge by distancel.
Ornament menu

this was trouble ome but manage to work it out. i think they should keep this and the old option to remove doubles.

Im having problems too. I have my objects joined (showing as one object in object mode) and I have tried Merge by distance from both the mesh and vertices menus. Its still not removing my vertices.

If “Merge by Distance” gives the notice “0 vertices merged” then that means you do not have duplicate vertices (I have noticed for instance that the mirror modifier clipping does indeed join the vertices even though it did not with the Beta version Michael was using.). Also, in edit mode, ensure you have all vertices selected before running the operation.

If for some reason the vertices are not exactly on top of each other, you can try increase the “Merge Distance” in the operator panel:

If that still does not work, confirm you did indeed join your objects as Blender 2.8 allows edit-mode on multiple meshes so it can be confusing: In Object mode, Alt-A to deselect everything, then re-select your object to confirm it is indeed one object.

Privacy & Terms