Recover old save in UE 5.3

I’ve Googled. I’ve looked here. I’m a little surprised that reverting to an older save isn’t an easy-to-find thing. Anyway, working through the wrecker part of the course, I got myself in a jam and broke my graph. I though, “well, this thing autosaves all the time, so there must be some kind of revision control.”

But I can’t see how you really do that. So, is there a way to revert to an older save of the level I’m working on?

Also, and – are there any good resources that talk about how to set up a git for managing saves? I have git on my desktop, so using that would be just fine. But it’s not clear what files do what/go where.

If this has been asked and answered, please point me at where the answer is.

Thanks!

They should be in Saved > Autosaves

But it’s not clear what files do what/go where.

I’m not quite sure what you’re asking here, if you’re asking for a gitignore:

https://github.com/github/gitignore/blob/main/UnrealEngine.gitignore

Or are you unfamiliar with git?

HI Dan,

Thanks for getting back go me.

I did find the autosaves folder, but I’m not sure what to do with it. File/Open in UE doesn’t provide an option for opening files, just levels or stuff in the content drawer. None of that is versioned. That’s my real disconnect here. I see option to open things, but not prior versions of a level.

I see a json file and a Games folder with a bunch of umap files in the autosaves folder. Have no idea what to do with the files. (I understand json is just a data file like xml.)

Windows doesn’t associate umap files with UE and I don’t see any kind of option in the UE editor to open a umap file. Nor do I know if that’s enough to revert to an older revision.

Scenario is simple: How do I open a version of the level I saved in the past?

I feel like there’s a secret handshake pamphlet I didn’t get on orientation day.

File/open level gives me this:

image

No reference to the past versions of a level that I can find.

AND… even if I manually copy a umap file from autosaves to content folder (which seems like a clumsy way to manage backups), it still doesn’t show up in the file/open levels dialog. Fore example, “Main_Auot0” does not show up as an available level to open even if I put in the content folder.

image

As for git, I have it installed on my desktop and know how to use it to make repositories and versioned copies of files. If this were a C++ code file with header files, I’d be in business. (For example)

Presumably you just need to add it to the Content directory on disk.

Did you re-load the project after doing so?

So it’s still not quite clear what are you asking about exactly?

I did. Same problem. Here, I copied Main_Auto0.umap from autosaves to content. After restarting UE, it still does not show up.

It’s here:

image

But it’s not here:

Does it show up if you right click the folder in the Content Drawer and use Validate Assets in Folder?

It does. How interesting.

Hi, this restored only my level, but other file types like this Level Sequence animation are still invisible.
Can you please help?

Is it from a different engine version?

No, UE 5.3.1 was used for the creation of this Level Sequence animation file, and I am still on this version.

Do you have all the assets it references?

Yes, the map and other associated level sequence uasset files were not moved and are working.

Then I don’t know, sorry.

Thanks for looking into it @DanM
Seems to be solved by renaming the uasset in Windows Explorer.
I.e. Simply removing the _Auto1 bit.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms