Really bad performance for Udemy site / player

I had terrible video streaming from Udemy - but changing my DNS to cloudflare improved it instantly. Got the hint from a post here

Sadly in my case my DNS is already set to that. I changed it awhile back. For me it’s mostly time of the day based. Afternoon/early evening seems to be okay 90% of the time. Later at night, morning time completely useless. The response from udemy is as follows:

Thanks for your response!
Unfortunately, that’s not information that I have access to. I do know that our engineers are aware of CDN issues in certain parts of the world and are working on improving the user’s experience. However, I’m not able to disclose the specifics of this effort.
If there’s anything I can do to help troubleshoot beyond the VPN, let me know. If not, I’ll consider this case closed.

Which is a bit of a non-response to me. “working on it” is the equivalent of “go away” in my mind. Especially with a lack of specifics. I don’t know why they’re using cloudflare for their main website and a single host in the US for content delivery. Cloudflare also does worldwide content delivery. They do admit they have CDN issues, but can’t really give us any kind of information on a fix and this has been an on-going issue for a long time according to my google searches and this thread.

I’m in Tasmania, Australia and from 8.30pm onwards performance degrades to the point where it buffers more than it plays. By 8.45pm it is literally unwatchable and doesn’t load. That gives me < 1 hour each night for education which is abysmal (not to mention the time I waste reporting all of this to Udemy in an attempt to get a fix).

I tried my VPN set to Texas, Canada and a few other random places. I’ve tried incognito with all extensions disabled, reported all console errors to Udemy and cleared all data from my browser(s). No improvement. Every other streaming service works fine. Speed tests are fine.

Udemy has introduced so much stress and anxiety into my life when all I want to do is learn how to be a game dev. Never in my wildest dreams would I have thought I’d have obstacles voluntarily furthering my education. This is infuriating and discouraging.


I’m using a paid version of windscribe with the Canada West server. I know windscribe has a free version could you try it and see if that is one of their free servers? It might help you. If not it’s a simple uninstall. How’s internet access in Tasmania otherwise?

Using this particular windscribe server has basically alleviated all my udemy issues but I would prefer to use it without VPN.

Hey Crossmr,

Thanks for the quick reply. Internet in Tassie is fine otherwise. My connection is 50 up and 20 down and there are no issues for literally any other service I’ve used to this point in my life!

I downloaded Windscribe and signed up for a free account, joined Canada West and what do you know, flawless playback. It was just one video I tested it on and I’ll reserve my happiness until I can test it again at 8.45pm when it completely fails but this gives me hope.

I’ll post again once I have a definitive answer. Thank you!

I’m glad it worked thus far. Please let me know how it works at 8:45. I’m really wondering what it is that it going on with their CDN. I assumed in my case, since it was working with Canada west that it was simply an issue of their CDN reducing speeds to non-NA regions but if your VPN to texas didn’t work before that might not exactly be the issue, or it could be that your VPN was overloaded. Some free vpns don’t provide very good speed.

So I’ve been testing the Canada West connection since 8pm local time and it hasn’t been any better than without. Perhaps I got lucky last night because it was around 10.45pm when I was posting. I’ll try a few other servers on this Windscribe service.

I have a paid VPN service I was using last night (and other nights previous to this) to test the bad CDN theory (as it reeked of that to me too) and didn’t have any luck with those.

Back to the drawing board. :frowning:

Update 1: Having just disconnected and reconnected it is now just keeping up, but only at 144p. Far from an ideal viewing experience as it’s impossible to read any text on screen.

Update 2: It’s now buffering just as much as without the VPN. No change.

Update 3: It’s 9:30pm and I’ve chosen “best location” which it’s chosen as “Hong Kong - Victoria” and it can easily keep up with (forced) 720p. Very curious. Not sure if we’ve passed peek usage time or not. Will have to try this again tomorrow night between 8 - 8.45pm.

I’m sorry it didn’t hold up, but hopefully you’ll have more luck tomorrow. I really hope we can find a solution that works for everyone. It may be some combination of the path between the CDN <-> VPN <-> End user that is the real trick.

Yeah, I was hopeful for a bit there. I literally can’t read ANY text on the videos as it doesn’t get any higher than 144p.

The weirdest thing about this is that I have tried a few other non GameDevTV courses that I’ve got on Udemy and they work absolutely fine. Even in the peak times where I can’t get a GameDevTV course to work at all. I wonder if anyone else can test this on their end.

Udemy support told me to ask the Instructor but surely the videos are being uploaded using the settings Udemy give them. Perhaps @ben could weigh in on if there are any funky settings that may be causing this?

Same here but it doesn’t seem to be at any particular video or any particular time it seems to be rather random on my machine anyway.

I noticed that it seemed to work in Internet explorer which seems to be slow at everything else except Udemy.

I wanted to toss an update here. Now that I’ve started using Windscribe as a default VPN when viewing these videos, I’ve had basically no problems. In the last 3 weeks I’ve done 200+ lessons and only once or twice did I have an issue using the Canada West server. On those times I switched to US West, and carried on. This is going to be my default setup going forward, and it is free, so if anyone outside North America is having continuous buffering issues, please give that one, or another VPN of your choice a try and report here if it helps you or not.

you can use a chrome extension for resolving this problem just download the repo and use “udemy_video_preloader” load with unpacked extension

clone the repo
refresh the udemy page
and vola it works

Privacy & Terms