Raylib.h: No such file or directory

Hey, still idk why raylib isnt working. In course its really simple - download raylib and launch the workspace, but in practice im behind all day. Please help guys

Out of curiosity, have you tried to move your project outside of the raylib installation folder and then try compiling?

Does the behaviour also change if you remove MinGW from your PATH?

yup, i tried almost everything. I have temporary solution - i added raylib libs strict into mingw libs and its working while im running .exe file but… u know its not optimal solution and still while im debugging im getting error

I know that sometimes students have had to add the raylib source path into the PATH variable to get everything to play ball (you’d think Windows wouldn’t be buggy like this after 11 versions or so). What extensions do you have installed for VS Code?


Try disabling Clangd and Unreal Engine Tools, you might get a different error cause I suspect the real problem is VSCode not properly detecting the Raylib folder.

That error shouldn’t be showing up when you have the C/C++ extension installed. I do see that you have C/C++ extension pack enabled but not the C/C++ extension itself, I was able to replicate the issue when I left C/C++ extension pack enabled but the C/C++ extension disabled.

The extension pack does not automatically enable the other extensions and they need to be enabled individually.

sorry, but I dont really understand, so what i have to do to fix that issue?

You need to enable the C/C++ extension


omg you are boss bruh! thanks for your time and have a good night!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms