Propellor Confusions

Hi … Somehow my Empty rotates instead of my rotor ?

Second time viewport has gone dark with a point light ? Last time it corrected itself while I was concentrating on something else .

1 Like

Can you show more of your Outliner and Animation Channels? If the Empty is rotating, more than likely it’s either parented to something that’s rotating, or you have a Channel for rotating the Empty and thought it was for a different object.

I think you’re referring to being in Render Preview Mode; it’s dark because you haven’t set up any lighting in your scene yet apart from the default light. If you switch back to Solid Mode for now, it should look as you expect.

Also, not sure if you’re still having trouble with the posting interface, but please double-check where you’re posting your questions. You’ve put two of them in the Unreal forum, and although the admins can move them easily enough, you’ll be stuck that much longer if we don’t even notice your posts =)

@NP5

2 Likes

You posted in Unreal again. I’ll change it

2 Likes

Problems dishappeared when my Blender Dishappeared - Crashed :woozy_face:
Ill start again now from Saved point with 2 parents just finished …
Ill try get more outliner etc in Screenshot if I get the same problem again … Il try following more carefully…
Yes, Must have accidentaly hit the render button … :+1:
My propellers started out as Linked Duplicates and seem to have somehow lost links … Perhaps that was part of the problem ?

1 Like

Pleas remember the PARENT CHILD relation ships.

Those involves where you ORIGIN POINT (orange dot) is located.

Check the origin point! And if not in center of the object anymore, then do the Object > set origin > Origin to geometry.

The parent child relation is based of this origin point!

And be aware that a parent can be a child in a other parent relation ship. Its like a tree with many branches.

Also if you manipulate an empty, like scaling … yopy change the children too.
But this scaling behaviour is different then scaling the child object itself. It looks the same, but because of the relations, it has a different relation ship internally and can cause strange effect when decoupling those parent child relation ships.

Check:

  1. All origin points at the correct object location
  2. Scaleing must be 1
  3. Work from the world location 0,0,0 to build your model object (airplane) and placing empties (and relations ships). When done then you can move your airplane for animation.

Note: I thing you are very eager to make it work (fly), but get lost in the theory on how to do this. And missing steps in the process, which is very easy to do. Because Blender is still a difficult tool to master, when you don’t grasp the basics.

Have fun, be patient!

2 Likes

Thanks … Ill try that out … In the meantime Id started again from an older Plane save and got the animation functioning :grinning_face_with_smiling_eyes:… but ill try repair the


other which was finished off better

Just now something appears wrong with Camera View … It seems disconected from Camera …
Is it possible to remove Parents once Parented ? I Tried and all its children dissapeared with it :woozy_face:

1 Like

Use “Alt p” on a child element to remove the connection to a parent.

If you remove a parent object only that object will be removed.
The children how ever … if you remove the parent object the child objects go back to a situation before they were parented to to the deleted object.
Sometime you don’t see a change, sometime it does.
All depending if you manipulated the parent.

2 Likes

Ok . Thanks … I tried setting origins to geometry but it kept on doing dtrange things … Ill ty unparenting it then and start fresh … :+1:

I realized somehow the plane was mothered to the plane below …So I Alt p the parents away and after a lot of fiddling got 2 planes flying and rotating

2 Likes

I think having two planes at once probably just added to your confusion here, but well done getting it sorted in the end. :+1:

2 Likes


Was wondering what I did to the camera ? The smaller "screen indide screen is gone "
Tried to roll a barrel across the rosda but didnt seem to work …Perhaps it needs to be parented ?
Quit satisfying seeing my planes fly and rotate :slightly_smiling_face:
, hopefully im not disturbinmg your Easter Monday … :slightly_frowning_face:

1 Like

maybe you accidentally hidden the camera, see ouliner panel?

1 Like

I see you still have Lock Camera to Viewport ticked, so maybe what you’re looking for is Num0 to go back into camera view.

Just as Num1, Num3, and Num7 are a set of hotkeys for Cartesian views, I like to think of Num0 as belonging to that set as well.

2 Likes

That did it … Thanks !!!

2 Likes

Privacy & Terms