Projecticle Blueprint Not Binding

I’ve been following this tutorial but now I’m finally stuck on what seems to be a weird bug in Unreal. After refactoring the fire method to be in the aiming component, I went in to bind the projectile BP class to the aiming component.

I kept getting hard crashes when firing. I go look at the Tank BP and see that the Projectile BP is unbound from the component. If I rebind it, everything works fine. As soon as I re-compile my C++ code, the component loses the binding again.

I have tried clearing all the auto-generated files. I’ve also tried making a new BP projectile class, it doesn’t make any difference.

What is this bug, and how can I fix it? I’m using a newer version of Unreal, 4.24

Make the projectile class BlueprintReadWrite and then use the construction script to assign it instead of using the details panel.

That did the trick! Thank you so much for your help, I was very frustrated

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.