Problems launching game?

My PC always gets stuck at Validating Executable for Windows when i click launch from within the editor. Its done the same thing in previous projects; no clue as to why. After I hit cancle then try it again, it returns an unknown error. When I make the UE4Editor.exe set to run as administrator, then when i try the launch from editor again, it actully returns a pop up error that i am trying to run a 16 bit program on 64 bit windows, afterwards logging: “PackagingResults:Error: Error Launch failed! Unknown Error”, in the output log.
I did some research on this and found little information. Some guy’s problem was the substance plugin, which despite being disabled, I uninstalled with no difference to the problems. I tried deleting my binaries and trying from scratch with the same results. My next option is to uninstall every version of unreal engine including epic games launcher and having a fresh engine install from scratch. But that is probably a long shot anyway. i dismissed this problem in the past since I dont have a game ready for shipment anyway, but its come about again and still bothers me in the back of my head… Any possible suspicions as to whats going wrong?

Also something strange is that when i right click on my project file in windows explorer and hit launch it works this way; how does this method of launch differ from building and launching the .exe in the editor?

Have you tried building on another computer? I’d try that before re-installing the engine… I hope your problem is only with unreal and not a config setup in your OS.

I was thinking of sending my project to someone else to test if it works for them but I don’t have a spare gaming PC to try it on atm.

This is my tutorial project on github if you wanna give it a try:
(some references need the default starter content folder to be pasted into content)

Hey @Steve1222,

I downloaded your project and built it. seems to run ok. I have no plugin installed and running 4.15.1.
Seems to run fine. I built for winX64 without problem. I had to set the starting level thoush as my 1st try it would only build into a black window. Maybe you problem is more related to your Unreal Editor install, since your game runs fine.

I hope reinstalling the engine fixes it for you.

BTW, I like you scene. You put a lot of effort into that?

Well at least i know it is on my end then, and not a product of the projects being created. I will try a reinstall tomorrow. So strange how it produces a 16 bit .exe on my machine, or claims to. I dont think ive ever even heard anyone use the term 16 bit application before, lol.

I did get slightly carried away with the pillars and terrain after i put in the doors for a simple test; had to stop myself from editing it further to get back on track lol. Always liked editing levels so that is the easy part for me. The entryways and other aspects are uneven, but its just a test map so had to limit its detail to stay on track haha.

Privacy & Terms