Problem with the pins. the geometry seems to be showing

so i was working on the bowling scene and realized that there was some problem with the pins as on lighting the scene the geometry of the pins was showing at the area of the contact shadows. is it just all about changing the options like softness and distance and finding the right position, or is there a more defined way?

Eevee has ‘out-of-the-box’ very simple shadow calculations.

But I don’t think it’s the problem here?

  • Are your face normal pointing to the outside
  • Do the pins have the smooth-shader on?
  • Do you have pin duplication (two meshes on the same spot)?

good luck.

In the course you only turned on the smooth shading on for the pins. But this only makes them look smooth, the actual geometry of the pins is still low resolution. But since this geometry is used for the shadow calculation the shadows get weird in the final render like you can see here.

The easiest solution for this is to put a suddivision surface modifier on the pins, so their geometry actually becomes more rounded. If you set this to e.g. 4 for rendering you will have smooth shadows.

but doesnt turning smoothshading on, remove the sharp edges? like its there when you look at it in the edit mode but in the object mode its smooth.

Nope, smooth shading only adjusts the look of the material on each face so that it looks like it is smooth. But the actual face itself is still as flat as it always was. You can also see that if you look at the edge of the model. It is not rounded there, but still the same low poly as it always has been.

1 Like

Solved on Udemy Q&A.
This was some of the settings on the contact shadows of the lamps, The positioning of the lamps, radius and strengths of the lamps and a 3rd light was added to increase that as well.
The main issue was the smoothing value being too low.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms