Problem with DefaultPawn_BP

I have created the DefaultPawn blueprint and have selected it in the game mode and have placed it in the level too but still the DefaultPawn is being created from where I’m looking at the level.

I have the same problem. Did you solve it @Hallar_Azad ?

Had the same problem fixed it by going into the GameMode BluePrint class and in the Class Defaults tab change “DefaultPawnClass” to your BluePrint Pawn.

1 Like

Setting default pawn in the blueprint PB fixed it for me too. Thanks!

This has to be a bug in UE, right?

I dont think this is a good solution but a hack. Also this couldn’t be a problem with Unreal as the instructor could do this easily. The solution which helped me is by changing the world settings, and changing the game mode to BuildingEscapeMode_BP.

Privacy & Terms